Ask Your Question
0

Calc: text carriage return disappears upon re-open

asked 2015-01-08 19:05:51 +0100

Randy.Gallegos gravatar image

updated 2015-01-08 19:10:22 +0100

Using Calc 4.3.5.2 on Win7

I have some cells which are basically labels, have "text" cell-formatting, and have descriptions in them, for instance:

title of section
subheading

There is a carriage return after the first line (ctrl+enter). When I save this document as XLSX (inc. both Microsoft and Open Office varieties), and then close then reopen the file in LibreOffice, all the carriage returns disappear, rendering those cells:

title of sectionsubheading

It saves and reopens with formatting in place in ODF, however this document is being worked on with a user running Excel Mac 2011 (14.4.4), which doesn't recognize ODF. Nevertheless, that it won't read the formatting back even in LibreOffice is problematic.

Interestingly, those cells with the carriage returns, when saved with proper formatting on the mac first, will open with the carriage returns intact on my PC/LO machine. But if I save and close, that file will lose the carriage returns on both machines/programs.

Are there any workarounds I'm missing? User error? Bug?

edit retag flag offensive close merge delete

Comments

The XLS support might be more matured at this point of the game. Did you try?

Lupp gravatar imageLupp ( 2015-01-08 19:11:09 +0100 )edit

[quote]When I save this document as XLSX (inc. both Microsoft and Open Office varieties), and then close then reopen the file in LibreOffice, all the carriage returns disappear,[/quote]

I cannot verify this behaviour (V 4.3.5.1 on Win 8.1). A very simple example with a hard line break in a cell is reopened correctly so far after saving as .ODS, .XLS and as .XLSX (MS), too.

Might you provide an example, please?

Lupp gravatar imageLupp ( 2015-01-08 19:21:44 +0100 )edit

[quote]When I save this document as XLSX (inc. both Microsoft and Open Office varieties), and then close then reopen the file in LibreOffice, all the carriage returns disappear,[/quote]

I cannot verify this behaviour (V 4.3.5.1 on Win 8.1). A very simple example with a hard line break in a cell is reopened correctly so far after saving as .ODS, .XLS and as .XLSX (MS), too.

Might you provide an example, please?

Lupp gravatar imageLupp ( 2015-01-08 19:29:00 +0100 )edit

(Edited!)

A reminiscence. Some time, about a year ago, I got shown by the formula editor in Calc about 100 functions in Norsk (Bokmål) and a few others in Esperanto. The ghosts vanished only when I had put away my user profile and reinstalled LibreOffice completely on an advice by "oweng". It turned out as corrupted by a breakdown. (Restoring my templates and a few macros was easy then.)

Excuse the doubled comment above, please. It was due to a (forum-)software malfunction.

Lupp gravatar imageLupp ( 2015-01-08 19:37:41 +0100 )edit

I don't know how to upload a file to check, but I put a stripped down version here. I copy/pasted that cel into a new file, saved and opened it and the carriage return still broke: http://gallegosart.com/test.zip (5kb)

Randy.Gallegos gravatar imageRandy.Gallegos ( 2015-01-08 20:35:05 +0100 )edit

I also did a test with a fresh doc, not copy/paste from the other. Just recreated the format and saved as xlsx (microsoft) and it too opened without carriage return. So weird.

Randy.Gallegos gravatar imageRandy.Gallegos ( 2015-01-08 20:39:28 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-01-08 22:04:00 +0100

Lupp gravatar image

updated 2015-01-08 22:06:17 +0100

I just threw away a complete answer. After some testing I thought I might have advice when a hunch came to start another experiment. This ended up with the preliminary result that cells containing a hard linebreak were saved and reopened correctly if the character formats were uniform - at least for one character in front of and one behind the linebeak. There must be a bad interference between the line breaks and the internal "text field delimiters" needed for changing formats. That's clearly a bug. Maybe I will file a bug report if I don't find one already addressing the issue. I would prefer if you did. I personally never use xlsx.

Saving to .xls and reopening showed no problems of the kind during a short test.

edit flag offensive delete link more

Comments

I appreciate the confirmation--I filed a bug report.

Randy.Gallegos gravatar imageRandy.Gallegos ( 2015-01-08 22:26:15 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-08 19:05:51 +0100

Seen: 509 times

Last updated: Jan 08 '15