Ask Your Question
1

Why does auto-correct work in English for different languages?

asked 2015-01-26 10:19:31 +0200

Anijatsu gravatar image

Both my OS and UI for Libreoffice are in English. I've recently met a problem when Libreoffice Writer continously modified the text with Autocorrect for the English UK language, while I've been writing in Polish. The document was set to the Polish language.

In this case it fixes the "i" letter to uppercase when it is standing alone, while in Polish it's used as a conjunction meaning "and".

I haven't changed any program settings since installing it, so naturally deleting the user profile folder, thus resetting the settings, didn't change a thing.

I'm on Windows 8.1 64-bit, Libreoffice 4.3.5.

I don't know the current way to report bugs, since the Bug Submission Assistant is out of order and https://bugs.freedesktop.org has bug submission closed.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2019-07-04 12:11:17 +0200

ajlittoz gravatar image

The document was set to the Polish language.

How did you set that? (Provide more information editing your question or posting a comment; don't use an answer for something not a solution)

The common way to set a language for a document or part of it is through styles (paragraph or character). This is mainly for multi-language documents.

In the simple case of a document using a single language, you can

  • change the language for Default Style paragraph style in Font tab; this will propagate to all other styles
  • change the Default language for Documents in Tools>Options, Language Settings>Languages
  • use Tools>Language>For All Text

Note the second option will work only if you didn't modify Default Style (in which case, settings in the paragraph style override those in Tools>Options). It will also set the language for all future documents.

The third option is direct formatting and will play tricks on your back but it is a quick way to experiment.

edit flag offensive delete link more

Comments

The common way to set a language

Well, the common way is to simply use the dedicated input. I. e. to switch to the respective language using a method conventional for the operating system/desktop environment, such as Alt + Shift or a similar keyboard shortcut.

gabix gravatar imagegabix ( 2019-07-04 15:19:30 +0200 )edit
0

answered 2019-07-04 11:57:47 +0200

7clem gravatar image

I've had a similar issue with French. I don't remembrer exactly what fixed it but I had installed french language support explicitly, or additional dictionaries and changed the settings to english then back to French and it worked thereafter.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-26 10:19:31 +0200

Seen: 56 times

Last updated: Jul 04