Ask Your Question
0

How do I sort by date

asked 2015-02-01 06:12:27 +0200

Milliways gravatar image

updated 2015-02-01 06:14:03 +0200

I have data, imported from csv file. I have set date format on one column, and want to sort by date, but this seems only to sort by raw character values.

27/01/2015
28/01/2015
31/12/2014
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-02-01 08:35:28 +0200

Wildcard gravatar image

updated 2015-02-01 08:38:07 +0200

This almost certainly happens because of the import settings used when you opened the CSV file in the first place. Open it newly and find the "date" column, then play with the "column type" settings. (Text, dates, etc.) One of the "date" settings should be what you want. Also the check box "detect special numbers" may be applicable—I don't know what other data you are dealing with.

When dates are stored as dates, not as text, they will definitely sort correctly.

(If this answers your question fully, please click the green check mark.)

edit flag offensive delete link more

Comments

We may also apply the tool > 'Data' > 'Text to Columns...' to the range of dates wrongly imported as text type data. This will offer the same options as the csv import dialogue.

Lupp gravatar imageLupp ( 2015-02-01 15:16:37 +0200 )edit

Hey! I can't get my CSV file to sort by date. The file that this was created from I see is not in order of date. This is very frustrating since it should be so simple. I can't help that someone else (from work) can't enter things in order. However, it should be a simple fix. I am completely new to LO. I upgraded my Mac OS and my old Mac MS Office no longer is supported. Where do I go to "Data" > "Text to Columns"? From the upper pulldown menu or are these icons in the program? THANKS SO MUCH!

dagger gravatar imagedagger ( 2015-08-12 20:17:52 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-02-01 06:12:27 +0200

Seen: 14,229 times

Last updated: Feb 01 '15