Ask Your Question

Writer keeps adding back in two pages every time I export to PDF [closed]

asked 2015-02-06 13:23:22 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


I've been working on a document (an application form which someone else created as .doc). I saved it as .odt and then worked on it in libreoffice but had lots of problems with tables...

I couldn't seem to get them to fit together - some of them seemed to insist on having their own pages - even though I couldn't see any formatting marks or settings stopping them...anyway I managed to find workarounds to sort all of this but then...

When I was finished I exported to PDF and there were two more blanks pages before some of the tables.

I check the document again, go to the text before this table and delete, it deletes the two pages... I try and export again and adds the two pages back in again, not only in the pdf file but within libreoffice(i see repagination as a message across the bottom after 'exporting'...).

I've checked that 'automatically insert blank pages' is switched off - in writer settings but also whilst exporting from the menu. Any idea what could be causing this?

I can't really attach the file in question as it is as it has all my personal details in it.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-15 15:59:27.459737

1 Answer

Sort by » oldest newest most voted

answered 2015-02-07 05:09:42 +0200

ROSt52 gravatar image

It is difficult to impossible to pin-point the root cause without having the file at hand.

I would most likely do the following:
- Copy and paste as unformatted text all but not the tables into a new odt-format document
- Export this file to pdf and see if the 2 page disappear
- If they don't disappear copy and paste the text with out the last paragraph before a table and the first paragraph
- If they don't disappear write the document new
- If the empty pages disappear create tables in the new odt-format document
- Copy and paste the content of the tables in the doc-file, not the tables, into the the new tables of the new odt-format document.
- Reformat the document

In such a situation I typically keep notes on what I did and what the result was and create frequently back-up copies before I am doing the next change.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-02-06 13:23:22 +0200

Seen: 527 times

Last updated: Feb 07 '15