Ask Your Question
0

Calc displays keyed numeric input unexpectedly

asked 2015-02-09 21:28:45 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Preferences for Calc is set to "Convert only unambiguous".
New spreadsheet format cells number general Date formats M/D/Y,M/D

1) Keying 14+2 results in
14+2
I expected 16 to be displayed.

2) keying 1/2/15 displays ½/15 ; 1/2 displays ½ ; 1/4/15 displays ¼/15; 3/4/15 displays ¾/15

3) If the format for a cell is set to date, keying =14/2 displays 01/06/00 Shouldn't the cell get set formatted for number?

Thank you. language default-English (USA) Version: 4.3.5.2

edit retag flag offensive close merge delete

Comments

14+2 isn't a formula and will not be interpreted as one. +14+2 is.

What did you expect in cases 2) and 3)? Did you actually enter the "=" in case 3)?

Lupp gravatar imageLupp ( 2015-02-09 22:14:01 +0100 )edit

Thanks for your reply.

1) Sure would be nice if 14+4 were interpreted as a formula :-)
2) I expected dates to displayed since I entered 1/2/15 (i.e. M/D/Y )
3) I expected 7 . I did key in the equals. Clearing direct formatting displays 7 .

dgerman gravatar imagedgerman ( 2015-02-10 00:32:02 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-02-10 00:44:59 +0100

Lupp gravatar image

updated 2015-02-10 01:01:48 +0100

(I wouldn't call the Belize format for dates unambiguous) The M/D/Y pattern must be added explicitely to the 'Date acceptance patterns' under 'Languages' if you want to use it. An US install will regularly do it, but this may have been changed (or overridden ina dark way by a faulty user profile). If you actually wanted your example 1/2/15 to be interpreted the British way (D/M/Y) as 2015-02-01 do respectively.

"Convert only unambiguous" should not affect entering from keyboard but only applying VALUE functions. I lack complete knowledge myself.

Getting the "½/15" is surely due to the "AutoCorrect" feature which is acting as an AutoInCorrect feature every other time. I suggest you switch it off. However, it should not interefere here except you inserted a space between 1/2 and /15.

edit flag offensive delete link more

Comments

Not sure what you mean by " Belize format for dates".
I have US install and M/D/Y;M/D is shown under preferences, languages, date acceptance patterns.

Thanks for you comments.

dgerman gravatar imagedgerman ( 2015-02-10 02:36:51 +0100 )edit

Did what I wrote actally help in any way? I hope so.

But if your problems persist, I might look for additional advice.

["Belize format" is my slightly mocking name for the M/D/Y style of dates widely used only in Belize (and the US) as I was told. It has grave disadvantages, imo. Hope you can bear my meddlesome remark.]

Lupp gravatar imageLupp ( 2015-02-10 13:41:51 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-02-09 21:28:45 +0100

Seen: 95 times

Last updated: Feb 10 '15