Ask Your Question

Can't open via command prompt on Win7 [closed]

asked 2015-02-23 08:07:39 +0200

jobzombi gravatar image

updated 2020-08-16 01:48:44 +0200

Alex Kemp gravatar image

I'm running:

soffice "filename.ods or .xls"

I'm also including several parameters, like -o or -nologo, to see what works, but none do. With -view, it opens fine, but I don't want it read-only, I want to users to be able to edit it. I also tried using scalc.exe and it just loads and then crashes. When I try opening calc again it goes to the recovery prompt.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-16 01:49:52.378171

1 Answer

Sort by » oldest newest most voted

answered 2015-02-23 12:25:51 +0200

Lupp gravatar image

updated 2015-02-23 12:30:35 +0200

( @jobzomi -)This simply should tell us that "C:\Program Files (x86)\LibreOffice 4\program" (or whatever is the correct path on your system) is not among the search paths of the Win environment for the user you are while entering your command behind the prompt in your terminal window. LibreOffice is concerned insofar only by its installer settings which are not made up to add the program path automatically. You may do it on system level.

I do not understand what you say about the -view option.

edit flag offensive delete link more


Sorry I failed to point out that it is properly set in PATH, also I tried using the full pathname. This is why the application does actually load, but subsequently crashes. The -view parameter is used to open the file as read-only, by creating a temp copy of the file that is opened instead (in essence it is not a real read-only file, but that is LO's way of doing it). All files seem to open up fine using that parameter & I use it often, but I have one file that requires users to be able to edit

jobzombi gravatar imagejobzombi ( 2015-02-24 09:59:34 +0200 )edit

My "don't understand" was simply wondering you got an answer with one parameter but not with others or none. As you now describe the failure as a crash after LibO had started a missing PATH is no option, of course. I'm too way off Windows/DOS terminal interna to help you at this point. Hope someone else will. Did you already try to open your file from the DOS promp with a zipper (or even a text editor)? Does that work? If you get a problem there, too, it's OS stuff ...

Lupp gravatar imageLupp ( 2015-02-24 16:05:46 +0200 )edit

Question Tools

1 follower


Asked: 2015-02-23 08:07:39 +0200

Seen: 228 times

Last updated: Feb 23 '15