Ask Your Question

Footnote bug in Writer 4.2? [closed]

asked 2015-02-24 01:51:15 +0200

nsivin gravatar image

updated 2020-07-12 15:38:06 +0200

Alex Kemp gravatar image

I have encountered a serious bug in LibreOffice Writer under Linux Mint 17.1 Mate,running on a desktop PC. I have drafted a book in a 1.2MB .DOC file. It is divided into 7 chapters, and includes a number of footnotes in each. I began the individual chapters as .ODT files, but converted them while still revising them, and before combining them. I no longer have the early .ODT drafts.

Whenever I close the book file and reopen it, in the first footnote in each chapter, a blank paragraph and a tab are interposed between the footnote superscript and the first character (or space) in the note. The same thing happens under LO 4.4.0 on in the same setup on a laptop. I even tried opening the file on a computer running Word 2000 under Windows XP; there is no problem there. I have avoided Windows for two years now, and want to keep avoiding it.

I have to use a .DOC file for this book, since the publisher needs a Word file, and .DOCX and .RTF files under LO are even less reliable. Since I have not noted this problem with small files, I cut the file down to less than 100KB (by copying the first couple of chaters into a blank file), but this smaller file still exhibits the same bug.

Has anyone encountered this odd bug? Should I report it to Bugzilla?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-07-12 15:38:13.180776

1 Answer

Sort by » oldest newest most voted

answered 2015-02-24 12:50:30 +0200

ROSt52 gravatar image

The bug you observe could be related to little differences between a MS created doc-file and an LibO created doc-file.

I would try to find out what your publisher exactly does with the WORD file and see if this could also be done with an odt-file. Very often people say they need WORD files but at the end they don't.

edit flag offensive delete link more


The problem is that my publisher doesn't use Linux, and therefore can't open .ODT files.

nsivin gravatar imagensivin ( 2015-02-24 18:22:56 +0200 )edit

@nsivin, that's same as saying Chinese can't eat Finnish food. Equally as stupid. And as not so true.

rautamiekka gravatar imagerautamiekka ( 2015-02-24 18:53:26 +0200 )edit

I don't think that calling my publisher (Springer, the largest in the world) stupid will solve anything.

nsivin gravatar imagensivin ( 2015-03-02 23:28:41 +0200 )edit

@nsivin, maybe, but at least it shows you're not directly giving up to corruption.

rautamiekka gravatar imagerautamiekka ( 2015-03-02 23:30:49 +0200 )edit

@nsivin - If your publisher is Springer, recommend them to use LibO and save a lot of money for unnecessary MSO licenses.... and additionally replacing Windows by Linux. Like the city of Munich.

ROSt52 gravatar imageROSt52 ( 2015-03-04 11:07:06 +0200 )edit

Question Tools

1 follower


Asked: 2015-02-24 01:51:15 +0200

Seen: 233 times

Last updated: Feb 24 '15