Ask Your Question
0

Text Box is not updating after a paste in LibreOffice Calc version 4.4.

asked 2015-03-01 02:32:47 +0200

meolar gravatar image

updated 2015-03-01 07:02:05 +0200

In LibreOffice Calc 4.4.1.2 (English) in Ubuntu 14.04, Text Boxes do not update text information based on formulas (such as CONCATENATE or the NUMBERTEXT Add-in) after pasting new data into the cells upon which the formula is based.

Here is an example to make the problem more clear:

  1. In cell C1, enter “=CONCATENATE(A1,B1)”
  2. Open the Form Controls toolbar (under View on the menu) and use it to put a Text Box on the spreadsheet
  3. Right click the Text Box and click on “Control...” to open the Control Properties dialogue
  4. Click on the Data tab
  5. Type “C1” in the box to the right of “Linked Cell”
  6. Click the Design Mode On/Off button on the Form Controls toolbar
  7. Type something in cells A1 and B1. C1 updates and so does the Text Box
  8. Type something different in cells A2 and B2
  9. Copy cells A2 and B2
  10. Paste into A1 (and B1) Cell C3 updates, but the Text Box does not (unless you paste a second time).

It worked in the last version of LibreOffice I used. Text boxes based on numerical operations/functions seem to work still (i.e., the Text Box updates after pasting new information that the function uses).

It seems as though the Text Box is updated before cell C3 is updated (unless there is a numerical calculation or formula in it).

Is there a new setting I need to change in version 4.4?

Edit:

rost152

Thank you for the compliment and suggesting an answer to the problem. Unfortunately, your solution did not work for me.

AutoreCalculate was checked. Also pressing F9 or clicking Tools > Cell Contents > Recalculate does not change the contents of the Text Box.

Actually, I just retested with making a Text Box that is tied to a cell (C1) that contains “=A1+B1” in the same way as I described above in the CONCATENATE example. The same thing occurred.

The result cells (C1, in both cases) do recalculate on their own. Also the Text Boxes update to show the value in cell C1 when the value in cell A1 or B1 are changed by typing.

The Problem

If I paste new values in cell A1 and/or B1,

  1. Only the value in cell C1 changes (because it is automatically recalculated).
  2. The value displayed in the Text Box is not updated.

The Text Box is updated if I paste the new values in a second time.

The previous version of Calc (that came with Ubuntu 14.04 originally) did not have this problem.

I tried to attach an example file, but apparently, I need to have more than three “points” to be allowed to upload files. Sorry. Also I tried replying in a comment, but there were too many characters.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-03-01 07:37:28 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi - thank you +1 for the steps to reproduce... and I reproduce on Windows 7/64 & Version: 4.4.1.1

The way to refresh is Ctrl+Shif+F9.

I do not know when the change was made ... or whether it is intentional or if it's a bug.

edit flag offensive delete link more

Comments

Thank you!

Ctrl+Shift+F9 worked.

It is frustrating that I have to manually refresh like that though. If it is intentional, I would like to know what advantage it offers, because I don't see one.

I would give you a point, but the site won't let me.

meolar gravatar imagemeolar ( 2015-03-01 08:01:45 +0200 )edit

Glad you got the solution. However, if setting AutoCalculate to ON (background left of text gets darker and check mark appears) and you still have to recalculate using ctrl+shift+F9 then there you found a bug. May I ask you to report it?

I am also wondering a bit about ctrl+shift+ F9. Default it is only F9. However, the shortcut keys can be changed.

ROSt52 gravatar imageROSt52 ( 2015-03-02 01:36:21 +0200 )edit

I checked the key bindings (shortcut keys) under Tools > Customize... on the Keyboard tab. It shows

F9 = "Recalculate"

and

Ctrl + Shift + F9 = "Recalculate hard"

Apparently, when AutoCalculate is enabled, the "Recalculate" command and keyboard shortcut (F9) do not recalculate everything according to https://help.libreoffice.org/Calc/Rec... .

I reported the bug ( https://bugs.documentfoundation.org/s... ). If you/anyone would confirm it, that would be great.

Thank you.

meolar gravatar imagemeolar ( 2015-03-02 05:39:56 +0200 )edit

"Recalculate hard" = l learned something. Thanks!

Also thanks for the bug report.

ROSt52 gravatar imageROSt52 ( 2015-03-04 10:58:45 +0200 )edit
0

answered 2015-03-01 05:14:25 +0200

ROSt52 gravatar image

First of all thanks for the excellent description you provided!!!! Big complement!!!

I hope that the solution of your problem is the same as it was in my case when Calc did not recalculate as it was supposed to do:
Tools > Cell Contents > check AutoCaluculate.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-01 02:32:47 +0200

Seen: 655 times

Last updated: Mar 01 '15