Ask Your Question
0

How to format a Table of Contents

asked 2015-03-03 19:26:11 +0200

Sophron gravatar image

The default styles for a Writer Table of Contents are very resistant to change and the instructions on reformatting don't reflect what I see before me. Manual formatting works fine, but goes away with each 'update' run. Is there a way to manually format and Table of Contents with Styles that will stick? OR, can anyone direct me to a better set of instructions on How to Format a Contents page?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-03-03 19:48:56 +0200

alvarezp gravatar image

Modify the 'Contents Heading' and 'Contents 1 to 10' styles:

  1. Press F11 to open the Styles and Formatting panel.
  2. Click on the row you want to adjust. You'll notice that the corresponding style for that row will get highlighted in the Styles and Fornatting panel.
  3. Right-click the style in the panel and choose 'Modify...'

Consider that this answer is refering to the default styles used to format a TOC, but the style mapping between heading level and TOC level (Heading 1 in the document --> Contents 1 in the TOC) can be changed in the Styles tab of the "Insert Index/Table" dialog.

edit flag offensive delete link more

Comments

This modifies the Paragraph Styles. But there are also Character Styles that are adjustable.

  1. Edit/Insert Table or Field
  2. Under the Entries tab, click on each item (E - Entry, T Tab Stop etc) and select its CHARACTER STYLE below.

I spent hours trying to get my TOC to use the fonts I specified in the Contents 1 etc. Paragraph Styles, not understanding that it was still applying Default Style CHARACTER STYLE!

7beggars gravatar image7beggars ( 2016-05-30 02:59:20 +0200 )edit
0

answered 2015-03-06 22:28:37 +0200

Sophron gravatar image

updated 2015-03-10 22:06:57 +0200

Sorry, no joy. F11 controls the volume of the internet radio on my Mac. Certainly, I can open Styles and Formatting, but any changes I make are erased by the next 'update.' I have a simple Contents with two levels: a Chapter Name in small caps and below an explanatory line in smaller default text. LO insists on attaching the Chapter's page number reference to the explanatory line such that Chapters without the explanatory line are unnumbered in the Contents. LO also wants to number my Chapters. In LO 4.1 I never had any problems inserting a simple Table of Contents. With 4.2 I will have to return to the era before Styles and construct a Contents manually. OK, now I've got it and you are quite right. One minor point: the default Level 1 header was underlined and could not be changed from the Modify panel (may be a bug?), but it did change and update from the tool bar (turn underline off).

edit flag offensive delete link more

Comments

I'm talking blindly here, but I guess that, in your Mac, F11 is achieved by pressing Fn + Volume Up.

As for losing the changes, my guess is that you are directly editing the table of contents, and that is expected. The instructions I posted are correct: edit the Contents 1 style for modifying the formatting for the ToC entries that corresponds to lines taken from the Heading 1 style, and so on.

alvarezp gravatar imagealvarezp ( 2015-03-07 04:24:23 +0200 )edit

Got it! The default Header 1 was underlined and did not change from the Modify menu (may be a bug?), though it did change and update from the tools bar. Thanks.

Sophron gravatar imageSophron ( 2015-03-10 22:02:10 +0200 )edit

Glad it worked. If you could mark the answer as correct, I'd appreciate it.

alvarezp gravatar imagealvarezp ( 2016-10-22 20:59:53 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-03 19:26:11 +0200

Seen: 2,738 times

Last updated: Mar 10 '15