Ask Your Question
0

how to type a date

asked 2015-03-04 10:00:05 +0100

guanolto gravatar image

Hi,

I just upgraded from LibreOffice 3.6 to 4.4, in Ubuntu Linux 12.04. Now when I type a date, Calc does not accept it as a date. In the older version, I could type "4mar" and then as soon as I clicked Enter, in the cell would appear "04-Mar-15" (assuming that's how I've formatted that cell). Now, in the cell I just see "4mar". As far as I can tell, the program has kept all the same settings as before. How do I fix this problem, or get around it?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-03-04 12:41:30 +0100

karolus gravatar image

updated 2015-03-04 12:58:28 +0100

Have a look to Tools→Options→Languagesettings→Language→Date-patterns

I've added the Patterns ....;D+M;D+

Input 4+5 expands from pattern D+M to Date 2015-05-04

Input 4+ expands from pattern D+ to Date 2015-03-04
(missing Input-values are always substituted with Current Month or Year )


Additional Observations:
input Daynumber<space>abbreviated Monthname works also for me, except for March wich is in German Locale März ... so Calc seems to fail on german Umlauts

edit flag offensive delete link more
0

answered 2015-03-05 05:53:14 +0100

guanolto gravatar image

Okay. Thank you, Karolus!

So I just have to type "4 mar" [Enter] now instead of "4mar" [Enter]. That works fine for me, without having to change any settings. But it's helpful to know that those settings do exist.

I'm totally glad that I upgraded to version 4.4.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-04 10:00:05 +0100

Seen: 80 times

Last updated: Mar 05 '15