Ask Your Question
0

How do I write Hindi numerals in checkbox in Libreoffice Base?

asked 2015-03-11 06:43:51 +0100

nerdynamya gravatar image

I'm preparing a questionnaire to be printed using Libreoffice base and using check-boxes for the recipients to answer the questions. I went to Options-----Language settings-----Complex text layout-----General options and changed the numerals to Hindi. However, when I type in the Label field of the Properties window of that checkbox, I still get Arabic numerals. What is the solution?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2015-03-13 01:59:46 +0100

indavidjool gravatar image

When I need to type non standard characters in my text boxes I use Ctrl-Shift-u and type the Unicode Hex Code for the character (Linux, I think Alt+decimal code works on windows?). I tried this with Devanagari codes 092B but it does not display correctly on my system, it might however do so on yours?

Regards

edit flag offensive delete link more

Comments

Note that Unicode input methods vary according to platform.

oweng gravatar imageoweng ( 2015-03-14 04:14:53 +0100 )edit
0

answered 2016-09-17 13:58:09 +0100

petermau gravatar image

I am typing these characters using LibreOffice 5.2 using Linux-Mint and a keyboard set to English-GB with or without CTL set. This may not fix your problem but may give some background information.

The answer to your problem may well depend on the System you are using and the language defined, including keyboard definition. However: The Arabic numbers and Hindi (Devanagari ) numbers use different Unicode code points. Arabic uses (U+0030 (0) to 0039 (9). This is the same for US-ASCII, ISO-8859-1 and Unicode. For example: Some Arabic digits Unicodes (U+0030) 0 ---1 2 3 4 5 6 7 8 --- to (U+0039) 9 I can type these directly using my keyboard, as well as the technique shown below. You can also us insert special characters.

Hindi (Devanagari ) uses Unicode Unicodes (U+0966) ० --- १ ६---- to (U+096F) ९ This is Unicode only and is not supported by US-ASCII or ISO-8859-1. I cannot type these directly as these keys are not found on an English keyboard.

If you do not have a keyboard setup to enter these characters directly, with LibreOffice 5.1 onwards, you type the hexadecimal number of a symbol and press Alt+X.

In Linux hold CTRL and Shift the type U+ then the code. This is the technique I have used to enter the Hindi characters above. This assumes that you have selected a font that contains the Hindi characters... Peter

edit flag offensive delete link more
0

answered 2016-09-17 10:18:00 +0100

There seems to be a bug in Libreoffice that when Options-----Language settings-----Complex text layout-----General options and changed the numerals to Hindi, the numerals display in Arabic script.

I have gotten round the issue by changing the numerals type to System, instead of Hindi.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-11 06:43:51 +0100

Seen: 202 times

Last updated: Sep 17 '16