Ask Your Question
0

Thai Language is invisible in Office [closed]

asked 2015-03-18 05:13:23 +0100

bank.thanachai gravatar image

updated 2020-08-21 15:54:46 +0100

Alex Kemp gravatar image

I type this "Thank ขอบคุณ" but i can see only "Thank". Thai word is invisible in my office after i do software update. How to solve this problem. (i already install libreoffice-l10n-th but it doesn't work)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-21 15:54:55.763809

3 Answers

Sort by » oldest newest most voted
0

answered 2016-02-18 13:46:45 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In February 2016 the problem still is not solves. I have an .odt file containing Latin, Cyrillic, Greek and Thai characters that was displayed correctly under OpenOffice, but on LibreOffice the Thai characters display like little hollow squares. Just installed the newest version 5.1.0.3 but it does not solve the problem. PDF files made by this LibreOffice version display Thai characters the same way. Windows Office 2003 and the PDF reader work correctly. I am using Windows 10. Is that perhaps related? Is this yet another Microsoft Attempt to discourage LibreOffice??

edit flag offensive delete link more

Comments

To see Thai text, select a font with Thai support, like "Noto Sans Thai" (not included in Libreoffice)

dabisu gravatar imagedabisu ( 2016-02-21 19:08:46 +0100 )edit

Please try Tools/Options/View and UNcheck "Use OpenGL for all rendering (on restart)"

(You have to restart LibreOffice)

w2016 gravatar imagew2016 ( 2016-03-24 02:38:54 +0100 )edit
0

answered 2015-05-16 02:33:27 +0100

BenM gravatar image

Characters not appearing in any program are generally the result of two things:

1) The character set and/or language settings.

2) The fonts available to the program.

In the first case you want the character set configured to be UTF-8 and ideally you want that set for every program which represents text in any way, whether you can edit it or not. Depending on your operating system this may already be the default setting. If you use a POSIX based system this can also be set using the locale command.

In the second case, the fonts which include support for Thai characters (e.g. Arial Unicode MS or Code2000) to be accessible by LibreOffice. The means of ensuring this varies according to each operating system.

edit flag offensive delete link more
0

answered 2015-05-19 17:01:21 +0100

dabisu gravatar image

If i copy your text into my Libreoffice (windows 8), thai text is not displayed because my default font doesn't support thai. But selecting the text and choosing a thai font (for example Noto Sans Thai), thai text is correctly displayed. Maybe your problem is similar.

edit flag offensive delete link more

Comments

In theory modern operating systems should, if the charset is set correctly (e.g. to UTF-8), provide glyph replacement. So even though the Thai alphabet is not present in Times New Roman or Inconsalata, I can still print "Thank ขอบคุณ" in both LibreOffice and Emacs. You need both the character encoding and the fonts with glyph support. In Emacs the Thai characters were produced with the Thornburi font and in LibreOffice Tahoma was used.

BenM gravatar imageBenM ( 2015-05-20 09:25:35 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-18 05:13:23 +0100

Seen: 1,700 times

Last updated: May 19 '15