Ask Your Question
0

why is LibreOffice writer so slow on a 613000 chars odt document?

asked 2015-03-24 10:17:33 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I use LibreOffice writer 4.2.8.2 installed in Debian wheezy. When I load and edit a text file containing about 613000 characters (and some drawings) on my Intel i5 PC, LibreOffice is very fast (scrolling pages, writing text, ...) but after having switched some times to other applications (file manager, web browser, ...) LibreOffice becomes extremely slow: I have to wait several seconds to see what I have written; one (only one!) processor is 100% charged and this is the reason. I tried to increase the memory cache (256 MiB is the maximum allowed) with no success. What can I do apart from splitting my book into smaller sections? Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-03-24 14:30:28 +0200

ROSt52 gravatar image

613000 characters should be an approx. 150 page document.

I cannot comment on the utilization of processors in your Linux installation. You might better ask Linux specialists on this topic.

Creating a master document, which carries all your styles and setting for your document and splitting your document in smaller portions is what I recommend.

By doing so, you also reduce the risk of a big loss. Keep in mind, that what ever system you are using a failure can happen (Sad but well known examples: Spaceshuttle). Smaller files are smaller risks.

Additionally make sure that you have at least 1 additional back up copy.

edit flag offensive delete link more

Comments

Thank you. I have actually 269 pages and 87463 words. Every day I create more than a backup, but I agree on risks. I still prefer one document for my convenience, but I must admit that it's not a reasonable choice. So there is nothing to do?

gidici gravatar imagegidici ( 2015-03-24 14:44:09 +0200 )edit

As mentioned in my answer already, I would try get help in related Linux forums. There might be chance to tweak your system to perform faster consistently by keeping the RAM free of information from other applications.

Maybe there is even a hardware solution be increasing your memory. For this check specifications of your PC.

ROSt52 gravatar imageROSt52 ( 2015-03-25 03:06:14 +0200 )edit

@gidici, this sounds like swapping issue, but if that is happening, especially if RAM is low, disabling swap will lock the system up. If this is the whole truth, something more advanced must be done other than adding RAM.

rautamiekka gravatar imagerautamiekka ( 2015-03-25 03:14:34 +0200 )edit

Thank you. I have 3.8 GiB of RAM plus 4.0 GiB of swap space. Normally my system uses 1.9 GiB of RAM and 0.22 GiB of swap. LibreOffice uses about 300MiB of memory (94 MiB shared). I think this means that I must add more RAM. I tried disabling swap, but nothing changed.

gidici gravatar imagegidici ( 2015-03-29 00:26:14 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-24 10:17:33 +0200

Seen: 274 times

Last updated: Mar 24 '15