Ask Your Question
0

Libreoffice Writer - Most chapters missing from table of contents??

asked 2015-03-29 15:15:23 +0200

ChrisCrinkle gravatar image

updated 2016-03-06 13:42:52 +0200

Alex Kemp gravatar image

Hello there, I have formatted all chapters to the "Contents 1" style. I have inserted a table of indexes, but most chapters are missing.

How do i fix this? They are all using the same style so either they shoul all be there or none of them should!

I'm using 4.1.3.2 writer by the way. Cheers.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-03-29 22:45:41 +0200

AllanR gravatar image

updated 2015-03-30 10:38:57 +0200

By default, paragraph styles Heading 1, Heading 2 etc are pre-set in Tools > Outline Numbering for use as chapters.

Styles Contents 1, 2, 3 .... are normally used to format the appearance of the entries in the Table of Contents.

It's the Level number allocated to a paragraph style (in Tools > Outline Numbering) that determines what appears in the TOC, in conjunction with the "evaluate up to level", when you right-click on the TOC and select "Edit/Index Table".

By using the Contents 1 style for chapter formatting, you may need to adjust Tools > Outline Numbering to reflect this fact or re-jig using the default settings?

EDIT TO ADD: Another thought: I was caught out with missing TOC entries when I used paragraph styles which simply created Act 1, Scene 1, Scene 2 ....., Act 2, Scene 1, Scene 2 .... headings. I didn't add (or need) any heading tecxt of my own. I discovered however that you HAVE to enter some text (manually) at each heading in the document (a space character will suffice) otherwise the heading won't appear in the TOC.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-29 15:15:23 +0200

Seen: 798 times

Last updated: Mar 30 '15