Is it possible to change fonts/styles and spellcheck memo fields in LibreOffice Base ?

asked 2015-03-30 19:01:33 +0200

KenWaters gravatar image

updated 2015-03-30 19:04:04 +0200

I am newbie when it comes to LO, and am using an Apple Mac with OSX 10.7.5 with Filemaker Pro 10 database software. Ive looked in this forum, but I cant find anything concerning this topic. I've been using Filemaker Pro 10 to store essays and articles as memo fields in a database, sorted on a date field. In Filemaker I can change styles in the database forms, such as using italics, bold, changing fonts and their colours. Despite the form being set to a default font, I can cut and paste the articles which have different styles to the forms defaults, or edit them in situ, and Filemaker doesn't complain. I can also spell check the memo fields. However, I would like to escape from Filemaker's expensive clutches (The FM Pro 13 version is nearly £200)

However I can't do these things with Base memo fields (Im using LO Version: 4.3.4.1). Using the forms, the spellchecking icons are greyed out, tho I can spellcheck in Writer with no problems (so the UK dictionary is working). Also I can't change the font styles, you seem to be stuck with what you which you initially create. Am I not a programmer, but have had a look at the form's control and form attributes, and I can't see a way of override the form's defaults. Perhaps its not possible to do this with Base (at least not without a lot of work).

Any help and ideas would be appreciated

edit retag flag offensive close merge delete

Comments

Can you confirm: are you using a grid or a normal form? If the latter, have you opened in edit mode, and selected the text control (and confirm what kind of conrol it is) alone (Ctrl-click) open the Properties dialog and in the general tab click on the ... in the dialog box, try to accomplish what you want that way?

doug gravatar imagedoug ( 2015-03-30 20:26:06 +0200 )edit

Hi Doug I am using a normal form. I was opening the form by double clicking on it in the main database window, and then trying to edit, but as I said spell checking is greyed and I can't change fonts I have also tried going back to main database window, and clicking on edit on the Memo (LONGVARCHAR) fields and selecting properties, but I cant see any way of allowing the fonts I select to be overridden if desired. The control's properties are set to Multiline and max text length of zero

KenWaters gravatar imageKenWaters ( 2015-03-31 11:25:46 +0200 )edit