Ask Your Question
0

Slow save times for .odt files. [closed]

asked 2015-04-01 15:51:45 +0100

j_keiter gravatar image

updated 2020-07-09 11:49:25 +0100

Alex Kemp gravatar image

Langueage=English 4/1/15 Ubuntu 14.04 LibreOffice Version: 4.2.7.2 Build ID: 420m0(Build:2) Writer has very slow save times for .odt files. Around 6s for experiment.odt. I only changed one word with 87,567 words in it. It seems like libreoffice re-writes/saves the whole document instead of just the changes.
Went to my laptop with Ubuntu 12.04 and Libreoffice Writer Version 3.5.7.2 and experiment.odt saved much more quickly with no hesitations. Around 2s. Something has changed.
Saving as a .txt file fixes problem. Save is very fast. 250mS. experiment.odt is 336.5kB while experiment.txt is 538.4kB. The larger .txt file saves much faster?? Possibly a compression issue?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-19 18:55:10.532213

1 Answer

Sort by » oldest newest most voted
0

answered 2015-04-02 01:50:54 +0100

ROSt52 gravatar image

I recently observed that a reset of the User Profile accelerated start up and save time. However, I did really made tests and verified my observation. you can give it a try.For details please refer to: https://wiki.documentfoundation.org/U...

Additionally there can be many reasons for different save times.
- First compare the Load & Save settings in Tools > Options > LibreOffice
- Second your PCs OS and HW can also have an influence.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-04-01 15:51:45 +0100

Seen: 700 times

Last updated: Apr 02 '15