Ask Your Question
0

How to insert a [return] in a cell?

asked 2015-04-01 16:47:26 +0200

Alias duel zone gravatar image

updated 2015-08-28 11:41:33 +0200

Alex Kemp gravatar image

I'm actually using LibreOffice 4.2.3.3 on MacOS X Mountain Lion

I need to place returns in cells containing text. Just as usual when typing text.

I tried [⇧]+[return], [⌥]+[return} and I always fall on the next cell.

I tried to change Preferences:

LibreOffice Calc > General
☐ Press Enter to move selection

which does only change my [return] to a dead key.


How may I switch to a mode where my [return] key does work as most usually expected putting a new line exactly where I am typing?

If this isn't possible is there a way to remap any key or combination of keys so as to include [return] as fluently as possible?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
-1

answered 2015-04-06 14:34:58 +0200

Alias duel zone gravatar image

updated 2015-04-06 14:36:32 +0200

To place a return within a cell containing text, you have to type [⌘]+[return].

This is ununderstandable in a MacOS X context.

This is an error on a Mac in 3 ways:

  1. On MacOS X, the [⌘] key is reserved for commands and is never used to input text. The keys used to modify the keyboard mapping for input are [⌥], [⌃] and of course [⇧].
  2. The [return] is redundant with the [↓] (down arrow key), hence there was no real need to map the [return] key to move the cursor down (I have a more natural key for this function).
  3. Most of the MacOS X application are assigning to keys the most natural function everyone is expecting. The most natural function which might be associated to typing a [return] is to insert a return.
edit flag offensive delete link more

Comments

I can't speak specifically to Mac OS X Mountain Lion. However, the functions of the Ctrl key on Windows have been mapped to the Cmd key on Macs for decades. Your objection in this answer is to using the Cmd key for "text input" on a Mac. You don't discuss or acknowledge whether the solution from @karolus that I amplified in a comment, works or not.
The procedure identified is common to both LibreOffice and MS Office, although with different keystrokes. Both use the return key the same way.

JKEngineer gravatar imageJKEngineer ( 2015-04-07 17:41:01 +0200 )edit

As to the return key be redundant with the down key, that can be changed in the options menu. The return key can be set to move up, down, left, or right as appropriate for the spreadsheet. Again, the same as MS Office.

JKEngineer gravatar imageJKEngineer ( 2015-04-07 17:50:26 +0200 )edit
1

answered 2017-10-18 17:04:11 +0200

gurol gravatar image

While editing the cell press the following three keys: [fn] + Command [⌘] + Return [Enter]

edit flag offensive delete link more
0

answered 2015-04-01 17:11:14 +0200

karolus gravatar image

updated 2015-04-01 17:14:35 +0200

Hallo

First doubleclick the cell to go into direct input mode,
then type linebreaks with [ctrl]+[enter]

edit flag offensive delete link more

Comments

Sorry, it doesn't work: just jump on the next cell (down).

Alias duel zone gravatar imageAlias duel zone ( 2015-04-02 01:25:06 +0200 )edit

Works fine for me on Windows. I assume you need to use the Cmd key instead of Ctrl on a Mac. During initial entry there's no need to double click, just Ctrl-Enter where you want the text to wrap. When coming back to a cell to add a line break, you need to double click to edit it. I found that doing that and adding a line break in the middle of a string of text capitalized the following word!

JKEngineer gravatar imageJKEngineer ( 2015-04-03 01:41:13 +0200 )edit

I understand our misunderstanding. As indicated in my OQ, I have this problem on MacOS X Mountain Lion.

Alias duel zone gravatar imageAlias duel zone ( 2015-04-04 14:52:28 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-04-01 16:47:26 +0200

Seen: 2,861 times

Last updated: Oct 18 '17