Ask Your Question
0

LibreOffice Calc cell format not saving in xlsx format [closed]

asked 2015-04-07 16:36:58 +0200

Murf gravatar image

I have a document that is in xlsx format and I need to keep in that format. I am trying to make a change to a column of cells. (Hi lite column, format cell> change leading zeros to 6 or change type to text.) I then save the document(have it set to not ask me about saving in ODF format so it will keep its xlsx format. When I reopen the document, the column format has reverted back to leading zeros '1'. How do I force it to keep the change I am making?

TIA

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-20 00:40:29.198056

Comments

Is there a patch for this or some way of fixing it?

cr33d0 gravatar imagecr33d0 ( 2015-06-30 13:36:44 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-04-13 03:40:00 +0200

razon_22 gravatar image

I can confirm this behavior in 4.4.2.2. Please file a bug report here. One note on converting a number with 6 leading zeros to text format: The cell may show the six leading zeros, but that is not what is actually stored in the cell. If I enter 25 in a cell and format with leading zeros, then change it to text format, the cell will show 25, which is the correct value. If you need the zeros to be there after converting to text, you will have to add the zeros to the front of the number manually or with a formula.

edit flag offensive delete link more

Comments

Has this bug been fixed?

cr33d0 gravatar imagecr33d0 ( 2015-07-17 16:12:29 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2015-04-07 16:36:58 +0200

Seen: 724 times

Last updated: Apr 13 '15