Ask Your Question
1

How to fix auto-correcting date in base

asked 2015-04-24 17:33:54 +0100

bunni711 gravatar image

updated 2015-04-24 17:34:42 +0100

I have a date column in base set up as mm/yy which constantly auto-corrects the year I type to the current year. Nothing I do seems to change this. I updated to the current version but it's still an issue.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-04-25 04:06:14 +0100

doug gravatar image

Type in the day in using the following input syntax mm/dd/yy. Then when you save the data, it will save the way you expect and display mm/yy. Not saying Base should work like that, but it does.

If, on the other hand, you reformat the existing data that you have typed to display as mm/dd/yy then you will see that any mm/yy data that you entered previously which can be displayed as a valid mm/dd combination was so interpreted, meaning 2/13 was interpreted 2/13/2015. It's not an autocorrection, it is that Base is looking for a valid date and that is how it creates it, albeit not very intuitive and in a manner not very faithful to the mm/yy display mask.

(if this answers your question, please accept the anser by clicking the check (image description) to the left)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-04-24 17:33:54 +0100

Seen: 71 times

Last updated: Apr 25 '15