Ask Your Question
0

Outline numbering and docx: is it a bug or a feature?

asked 2015-05-05 18:07:02 +0200

Libre-user01 gravatar image

updated 2015-08-27 20:32:33 +0200

Alex Kemp gravatar image

Version: LO 4.2.7.2, English OS: Linux Mint 17.1, English

I also asked this question at http://en.libreofficeforum.org . Sorry for the double post but I do not know if the people here know more.

I’m trying to create a document that I have to share w/ some people, so LaTeX is out of the question. Therefore I must use the docx format (Microsoft Word 2007 and up).

I want to automatically number the chapters in my docx. So what I do is the following: I make a new document, save it as docx, close Libre Office and reopen siad document, type text, assign the styles Heading 1 for the chapters, Heading 2 for the sub-chapters etc.

Then I apply Outline Numbering like so: Tools > Outline numbering > Level 1 = paragraph style “Heading 1” > Number = “1, 2, 3 …” > Separator after = “. “. Repeat process for Heading 2 and 3.

So far so good. The capters and sub chapters get numbered and when I add a chapter (i.e. Heading 1) then it gets the proper number, for instance number 2 for a chapter after chapter 1 etc.

Then I save and close the docx. When I want to add text and chapters the next day the “bug or feature” kicks in and it drives me crazy to the point that I want to pull my hairs out an scream ‘till I’ve got no voice left. When I want to add a chapter then I type some text and apply the style “Heading 1”. But no chapter number. When I go to Tools > Outline numbering then I see to my surprise that the outline numbering for Heading 1, 2, etc. is gone! WTF???? Libre Office somehow converted the outline numbering to “regular” numbering and no way that I can give my newly added chapter the proper number. Because when I “redo” the outline numbering then it starts to number my chapters from the new chapter onwards and the chapter numbers are all mixed up. Even if I place the cursor in the first chapter and apply the outline numbering.

Just try it yourself. Make a new docx, apply outline numbering and try to add a chapter after reopening the docx. You won’t succeed, I swear!

If I try this in an .odt document then I do not have these problems so I think that this is a bug in LO. I cannot imagine something this basic not working in Libre Office. And I can remember that I had a lot of problems numbering chapters in Open Office some 5 years ago too. Is this a Libre Office thing? Is it a bug or a completely un-intuitive feature?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-05-07 15:29:43 +0200

Libre-user01 gravatar image
edit flag offensive delete link more

Comments

Bump. Anyone w/ an answer?

Libre-user01 gravatar imageLibre-user01 ( 2015-05-12 19:25:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-05-05 18:07:02 +0200

Seen: 478 times

Last updated: May 07 '15