Ask Your Question
0

Why I can not update Libre Office without complications?

asked 2015-05-08 21:39:26 +0100

Light Code gravatar image

updated 2015-09-27 19:26:19 +0100

Alex Kemp gravatar image

The problem ocurs after any update. It doesn't matter from wich or to which wersion I update to. After updating, formulas won't display properly in Writer. Problem occurs with writing new formulas as well as old files, which were previously good. As for now the only cure for this, is to uninstall the program and make a clean install. Then it works perfectly. Problem is quite easy to solve, but constant neet to make a clean instal is getting anoying.

Screen capture shows formula panel with the problem present. Same symbols are present in written formulas:

formula panel

Tech info:

  • Component affected: Writer; Math; all Windows versions.
  • Program version in use: 4.4.3 (fresh).
  • System version: Windows 7 Professional; SP1; 64bit.
  • Localization: PL
edit retag flag offensive close merge delete

Comments

I had the same issue after updating to 4.4.3 Still. I fixed it by updating to LO Fresh. It didn't happen when I updated from 4.5 Fresh to 5.0.0 x64, but now, it's doing it again after updating to 5.0.1 x64.

  • System: Win7 sp1 64bit
  • Localization: En
Gugg gravatar imageGugg ( 2015-09-11 01:27:56 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-09-15 15:03:40 +0100

Alex Kemp gravatar image

updated 2015-09-16 20:29:23 +0100

Hi Light Code

My constant thought, reading these questions, is that there must be a special hell reserved for software-writers.

The screen-shot that you show is of the Function listing in the left-hand pane. Everything looked fine on my screen for that listing (LO-5.0.0.5 Debian 6.0).

There are 2 things that I can think of for you to check and/or do:-

Check Fonts

If the font that your system is using within Math does not have glyphs for certain chars, then you will obviously have problems. The fonts are sourced from your system, although LO/OO also arrives with some fonts when installed.

(menu):FormatFonts...

Formula fonts are all Liberation Serif on my system
Custom fonts are also Liberation on my system:-

  • Serif: Liberation Serif
  • Sans-Serif: Liberation Sans
  • Fixed-Width: Liberation Mono

If there is a problem with the font used, then LO/OO offers a method for substituting fonts:-

(menu):ToolsOptions...LibreOfficeFonts

Restore a Default Profile

I would suggest that you Restore a Default Profile as the very first action (the actions below are easily reversible).

Note that when you uninstall LO/OO it does NOT uninstall/delete the profile.

The profile contains a user's setup.

"If you notice any strange behaviour on LibreOffice, or simply it fails to start, the first thing to try is to reset the user profile."

  1. Shut down LO/OO (also quickstarter)
  2. Find your profile
  3. Rename the dir/folder

If this helps then please tick the answer (✔)

edit flag offensive delete link more

Comments

Doesn't work for me... I just updated my laptop from LO 5.0.0 to 5.0.1 and encountered the issue again. So I checked the fonts used in formulas and they are all still the default liberation fonts. Then I closed LO, renamed my profile folder and opened a file containing formulas. The formulas are still broken.

Gugg gravatar imageGugg ( 2015-09-29 20:28:30 +0100 )edit

Sadly if only fonts were the case I would somehow managed to find this reset option. As I said, after a clean install, the problem is always solved, without the need of changing the fonts (the info about the fonts used is not deleted while deinstalling). What is more, all fonts installed on my computer have glyphs for the chars needed. In my opinion there is something not right with the update procedure.

Light Code gravatar imageLight Code ( 2016-10-20 08:57:10 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-05-08 21:39:26 +0100

Seen: 190 times

Last updated: Sep 16 '15