Ask Your Question
0

How to make LibreOffice 3.6 seeType 1 fonts under ubuntu/bodhi [closed]

asked 2012-08-19 17:36:01 +0100

tigerdog gravatar image

updated 2015-08-30 00:23:53 +0100

Alex Kemp gravatar image

I am using LibreOffice 3.6 on Bodhi Linux 2.0.1 (a ubuntu 12.04 derivative). All other applications on the system list and properly display/render my Type 1 fonts. LibreOffice does not display them in the dropdown list. Fonts are installed in /usr/share/fonts/Type1. Extensions (.pfb and .pfm) are all lower case.

How can I fix this?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-16 18:18:43.898449

3 Answers

Sort by » oldest newest most voted
0

answered 2013-02-22 23:50:36 +0100

qubit gravatar image

Hi @tigerdog,

Are you still seeing the same problem when you test using the latest release?

If so, please file a bug about this problem, and provide a list of steps that can reproduce it. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more

Comments

@jmadero.dev, you're a Bodhi user, right? Any repro with Type1 fonts?

qubit gravatar imagequbit ( 2013-02-22 23:51:36 +0100 )edit

Yes, Bodhi user, currently running 2.4.0 with LO 4.1.3.2. Problem is still present. Seems to be a bug first reported over a year ago. See fdo#37453

I am currently running Bodhi 2.4.0 but see the same behavior under Xubuntu 12.04. Last tested using LibreOffice 4.1.3.2. Sadly, still no luck. I am reasonably certain the Type 1 fonts are installed correctly by the system. They are seen and usable from other applications including Leafpad and Abiword. Only LibreOffice (and OpenOffice, when I tried after writing this post) have this issue.

@jmadero.dev, yes, I use Bodhi but also Xubuntu. Same problem exists in both. New TrueType fonts are recognized by LibreOffice and other system apps. Type 1 fonts are not seen by LibreOffice. Other apps (leafpad, Abiword) detect and properly display added Type 1 fonts.

FWIW, this problem does ...(more)

tigerdog gravatar imagetigerdog ( 2013-12-22 06:30:40 +0100 )edit

see my answer below. For some unspecified reason, LibreOffice requires both the .pfb and corresponding .afm file before it will display a font. Other Ubuntu apps only require the .pfb.

tigerdog gravatar imagetigerdog ( 2013-12-23 19:17:57 +0100 )edit
1

answered 2013-12-23 19:16:19 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have an answer, though not a happy-making one. LibreOffice (at least 3.6 and 4.1) require the font's .pfb and .afm files to be present. If you don't have both, LibreOffice will not display the font in the font list. This is different to most other programs that are happy with only the .pfb. This requirement is verified by one of the LibreOffice developers in this LibreOffice Bugzilla bug comment.

There's a relatively simple workaround, at least for Ubuntu and variants. Create afm files from your pfb files using fontforge.

  1. install fontforge using apt-get, synaptic or your favorite method
  2. Create a text file similar to the one in this example, section "Using Loops". Replace ".ttf" with ".afm"
  3. Save the text file in the same directory as your .pfb files, with the name "CreateAfm"
  4. cd to the directory with your pfb files and execute fontforge and invoke the script using the command

    sudo fontforge -nosplash -lang=ff -script CreateAfm *.pfb

This will create .afm files, based on your .pfbs. When the files are generated, force a complete rescan your font folder with the command

 sudo fc-cache -f -v
edit flag offensive delete link more

Comments

Related bug is fdo#70184 (although it is likely to be RESOLVED as NOTABUG). Note that Type 1 file requirements are:

  • Linux: pfb + afm (pfb can be pfa)
  • Mac: pfa + afm (+optional inf)
  • Windows: pfb + pfm
oweng gravatar imageoweng ( 2013-12-24 00:47:32 +0100 )edit
0

answered 2012-09-08 17:30:17 +0100

I have a quick fix. First, create a .fonts folder in your home directory. Then install the "gnome-font-viewer" in Synaptic, double click on the font you want to install, then click install. Voila! You should have it automagically appear in Libre Office.

edit flag offensive delete link more

Comments

this does not fix the problem. whether installed in the system font directory or /home/username/.fonts, the problem is the same. Whether installed manually or using gnome-font-viewer, the issue is the same.

tigerdog gravatar imagetigerdog ( 2013-12-22 06:32:19 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2012-08-19 17:36:01 +0100

Seen: 1,841 times

Last updated: Dec 24 '13