Ask Your Question
0

How to add ttf font files to LibreOffice on Linux?

asked 2015-05-16 22:03:26 +0200

HarveyP gravatar image

updated 2015-05-22 09:29:07 +0200

I have a particular ttf file (Binner Gothic) which I once put in 'C://Windows/Fonts' ... but now I use Ubuntu Linux and I can't find an obvious place to put it! '/usr/share/fonts/truetype/openoffice/' looked good until I saw its contents - just 'opens___.ttf'

Having read the two responses below, I tried each, but neither caused 'Binner Gothic' to appear in the selection dropdown, nor was the font recognised by a document saved with BG. Neither folder existed, and therefore each was empty. Where are the other fonts stored?

edit retag flag offensive close merge delete

Comments

just for fun I've google for binner gothic.ttf download and doubleclick →→install

the file is now in

/home/karolus/.local/share/fonts

and after restarting Libre the Font is available under Name binner ... (all this on LinuxMint ( a distribution close to ubuntu ))

karolus gravatar imagekarolus ( 2015-05-22 11:25:13 +0200 )edit

It is important to restart LibreOffice (specially if LibreOffice QuickStarter is enabled)

Ljiljan gravatar imageLjiljan ( 2015-05-25 22:09:24 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2015-05-16 22:30:04 +0200

karolus gravatar image

move it into /home/<you>/.local/share/fonts/

edit flag offensive delete link more

Comments

This is the correct answer for recent versions of Ubuntu. .fonts has been deprecated for a while, IIRC.

KH gravatar imageKH ( 2017-12-08 05:12:27 +0200 )edit
0

answered 2017-12-09 01:20:13 +0200

nu-linux-usr gravatar image

I used this link to assist with the installation... it may or may not help you but thought I share.

https://www.pcworld.com/article/28634...

edit flag offensive delete link more
0

answered 2015-05-18 08:27:29 +0200

Ljiljan gravatar image

The easiest way to do this is to create ".fonts" folder in your home direcoty (eg. /home/your_account_name/.fonts/") and just copy your fonts there.

edit flag offensive delete link more
0

answered 2017-12-08 04:10:37 +0200

I have a dual-boot machine. Here's what I did: 1/ Set my Windows drives to auto-mount. I followed the directions at https://askubuntu.com/questions/12323... choosing the visual way (GUI). Reboot is required at this point. 2/ I navigated to my windows folder (C:\Windows), and created a link to the fonts folder. I moved that link into my Ubuntu home folder, and renamed the link to .fonts Now all my windows fonts are available in LibreOffice (Ubuntu)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-05-16 22:03:26 +0200

Seen: 10,979 times

Last updated: Dec 09 '17