Ask Your Question
0

Libre Office 5.0.0.0 x64 (Writer) - Immediate Crash on Start Up.

asked 2015-05-31 10:44:18 +0200

ericm gravatar image

updated 2015-09-27 18:23:09 +0200

Alex Kemp gravatar image

Good afternoon all, I've been trying in vain to fathom why I can't get LO5.0.0.0 X64 to run for more than a few seconds. Hopefully someone out there can give me a useful lead to follow up.

I have no problems with my LO4.4.3 set up, but thus far all versions of the x64 LO5.0.0.0 builds I've tried (Nightly / Alpha / Beta) display the same behaviour - UI crash on document load.

Steps :-

open Libre Office (Office start menu.) select existing document (any document) to open. Document loads and writer immediately crashes when load is complete.

or:-

open Libre Office (Office start menu.) select create new document Writer loads and immediately crashes when new document template load is complete.

or: -

open Libre writer Writer loads and immediately crashes when new document template load is complete.

In all cases, the office.bin process remains running after the UI crashes. The Behaviour is the same with a completely fresh profile.

Aside from being a little suspicions about JRE, I'm out of ideas. Any suggestions before I post to bugzilla?

Regards Eric M

Libre Office 5.0.0.0 x64 Beta 1 (and x64 Alpha) on Win 7 x64 JRE 8.45 (Both x86 and x64) Libre Office 4.4.3 runs faultlessly on the same platform.

edit retag flag offensive close merge delete

Comments

I tested some features for old bugs and "just so" with 5.0.0.0 Beta1 under Win 8.1 and got some crashes (not too few), in specific if I had many files open. I never got a crash under the conditions you describe (neither with Writer nor with Calc)..

Lupp gravatar imageLupp ( 2015-05-31 11:26:54 +0200 )edit

You would seem to be confirming my fears Lupp ;) . Alongside your experience, there is a lack of anything similar on Bugzilla. All would point to something in the system environment being the problem - but I'm drawing a complete blank on what that might be.

ericm gravatar imageericm ( 2015-05-31 11:46:12 +0200 )edit

I experiencing the exact same issue with LibreOffice 5.0 RC1 and 4.4.3. Resetting user profile and complete reinstall did not fix the issue. Even trying to create new documents results in the same issue. Win 7 SP1 x64 Java 8 Update 45

Sweeney gravatar imageSweeney ( 2015-06-25 13:31:59 +0200 )edit

v5.0.0.2 seems to fix this issue. Works for me.

pquiring gravatar imagepquiring ( 2015-06-29 15:19:46 +0200 )edit

4.4.4.3 crashes suddenly on open of any document type. The only thing I can see that changed since this morning, when LO opened just fine, was some Windows updates and a Java update. Unfortunately, it is impossible to tell which update may (or may not) have caused the issue.

Jim Roper gravatar imageJim Roper ( 2015-07-28 19:58:32 +0200 )edit

@Jim Roper : I got such updates, too (for Win 8.1), and the behaviour of LibreOffice did not change (neither with my "production" version which is 4.4.4.3 nor with the testing version which still is 5.0.0.0beta3 here).

Lupp gravatar imageLupp ( 2015-07-28 20:43:47 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2015-06-14 17:23:27 +0200

Having this exact same issue. Completely fresh install of 5.0 beta3 Win 8.1 x64

Just uninstalled Apache Open Office, installed LO... literally unusable. Crash on launch every time, every variation. Really frustrating introduction to LibreOffice. Now I have to go redownload and install Apache....

edit flag offensive delete link more
0

answered 2015-06-26 15:58:31 +0200

pquiring gravatar image

updated 2015-06-26 16:19:43 +0200

Me too, the 5.0 Alpha releases were working fine. Then with the Beta 1-3 and 5.0.0.1 it's crashes as soon as I open a file or create a new document. 5.0.0.1 32bit works fine. It's just a 64bit issue.

edit flag offensive delete link more
0

answered 2015-08-30 21:23:09 +0200

ericm gravatar image

UPDATE: The crash was caused by a problem in the grammar checking module. The crash was restricted to x64 versions and could be avoided by switching off the auto grammar check. The issue was resolved before general release.

edit flag offensive delete link more
0

answered 2015-06-22 22:07:01 +0200

tovtix gravatar image

same proplem. Win 8.1 x64, Libreoffice 5.0.0.1 (x64), java 8 31 x64, Writer always crushes

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-05-31 10:44:18 +0200

Seen: 1,390 times

Last updated: Aug 30 '15