Ask Your Question
0

edit .pps in impress

asked 2015-05-31 19:11:12 +0200

moshebagelfresser gravatar image

Impress doesn't let me edit a .pps on finish shuts down impress.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2015-06-02 09:16:52 +0200

moshebagelfresser gravatar image

I tried JohnD's answer and that didn't work changing from .pps to .ppt. I don't know if it's a Linux Mint 17.1 problem in renaming the suffix or LibreOffice problem.

What happens is even if I open it after renaming it automatically displays the presentation. On pressing Esc, Impress exits.

I saw on https://forum.openoffice.org/en/forum... a script:

#!/bin/bash
#script to open pps files in edit mode in Ubuntu
#script contains code found on several places on the internet and can handle only one parameter (file)

fullpath=$1
filename="${fullpath##*/}"                      # Strip longest match of */ from start
dir="${fullpath:0:${#fullpath} - ${#filename}}" # Substring from 0 thru pos of filename
base="${filename%.[^.]*}"                       # Strip shortest match of . plus at least one non-dot char from end
ext="${filename:${#base} + 1}"                  # Substring from len of base thru end
if [[ -z "$base" && -n "$ext" ]]; then          # If we have an extension and no base, it's really the base
    base=".$ext"
    ext=""
fi
extnew=$ext
if [ "$ext" == "pps" ] || [ "$ext" == "PPS" ]; then
   extnew="ppt"
fi
if [ "$dir" == "" ]; then
   dir="."
fi
oldname="$dir/$filename"
newname="$dir/$base.$extnew"
mv "$oldname" "$newname"
ooimpress "$newname"
mv "$newname" "$oldname"

Save it as ooimpress-noshow, do chmod a+x ooimpress-noshow

The script is for OpenOffice Impress, how would I alter it for LibreOffice, and where should it be saved to work?

edit flag offensive delete link more
0

answered 2015-06-02 19:38:29 +0200

pierre-yves samyn gravatar image

Hi - Simply:

  1. File Open Your.pps (the slideshow starts)
  2. Right clik, Edit the presentation

Regards

edit flag offensive delete link more
0

answered 2015-06-01 01:19:49 +0200

JohnD gravatar image

Change the file extension from .pps to .ppt and then it should open in edit mode.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-05-31 19:11:12 +0200

Seen: 821 times

Last updated: Jun 02 '15