Ask Your Question
0

Spellcheck, 2nd language

asked 2015-06-02 19:11:28 +0200

LibreGuy gravatar image

updated 2015-06-02 19:20:57 +0200

Hi guys,

English is not my native language, hoewever sometimes I use English words in my texts. These words do not get recognized by the spellcheck since the spellcheck is set to my native language. Therefore the spellcheck thinks I made a mistake.

I do have the English dictionary installed. I wonder if there is a way to tell the spellcheck that a specific word is written in English. Does anyone know if this is possible?

(Or is it perhaps possible to have spellcheck for 2 languages at the same time?)

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-06-19 23:13:16 +0200

LibreGuy gravatar image

I have been trying the solution from m.a.riosv for a while now. This one:

Or select the word(s) and Menu/Format/Character/Font - Language - English.

The problem is that this somehow is not saved. Next time I open the document, the specific word has been reset to my native languague, and spellcheck thinks it's a mistake again. So the word is underlined in red again. Is there maybe another solution?

edit flag offensive delete link more

Comments

Right-click the (underlined-in-wavy-red, English) word & choose "Add to dictionary". That will mean that your non-English dictionary gets polluted with English words, but it will get rid of the spell-check mistakes. I only hope that you are a good English speller.

Alex Kemp gravatar imageAlex Kemp ( 2015-06-20 13:06:51 +0200 )edit

Hi Alex. That is indeed what I could do (and sometimes do) but like you said, my non-English dictionary gets polluted with English words, so I was hoping to find a solution to prevent this. But I'm afraid that there's no other solution. It seems one can't "mix" English and non-English words.

LibreGuy gravatar imageLibreGuy ( 2015-06-20 16:38:13 +0200 )edit
0

answered 2015-06-02 19:25:37 +0200

m.a.riosv gravatar image

updated 2015-06-02 22:21:55 +0200

Select the word(s) and in the status bar click on you language and select English.

Or select the word(s) and Menu/Format/Character/Font - Language - English.

Edited. The second option works for Calc also.

edit flag offensive delete link more

Comments

Thanks, but where can I find the language in the statusbar in Calc? I do see it in Writer, but not in Calc.

LibreGuy gravatar imageLibreGuy ( 2015-06-02 19:40:25 +0200 )edit

Sorry I did thinking it was in Writer.

m.a.riosv gravatar imagem.a.riosv ( 2015-06-02 22:20:00 +0200 )edit

Any one else a suggestion maybe?

LibreGuy gravatar imageLibreGuy ( 2015-06-03 01:35:42 +0200 )edit

I had edited my answer the second option works in calc.

m.a.riosv gravatar imagem.a.riosv ( 2015-06-03 03:23:28 +0200 )edit

I was hoping for the first solution to work, because it's a bit more user-friendly. However, better a solution than no solution at all. Thank you!

LibreGuy gravatar imageLibreGuy ( 2015-06-03 11:37:37 +0200 )edit

You can set the language for the cell with the cell style or changing the cell format. What could help a bit is create a shortcut or add an icon in the toolbar (Menu/Tools/Customize) to access quicker at the character format.

m.a.riosv gravatar imagem.a.riosv ( 2015-06-03 23:38:52 +0200 )edit

Please what is your LibreOffice version, and the file format used to save?

m.a.riosv gravatar imagem.a.riosv ( 2015-06-20 01:37:43 +0200 )edit

Sorry, I didn't see your question earlier. I use ODF Spreadsheet (.ods) to save my Calc document. I use version 4.4.3.2.

LibreGuy gravatar imageLibreGuy ( 2015-06-21 15:08:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-06-02 19:11:28 +0200

Seen: 115 times

Last updated: Jun 19 '15