Ask Your Question
0

Why am I getting a white background behind text (titles and subtitles only) in LibreOffice Impress? [closed]

asked 2015-06-04 22:58:06 +0100

Roland Taylor gravatar image

updated 2015-06-05 18:46:18 +0100

I'm not sure if this is a bug or a setting, since clearing my configuration completely causes the problem to go away in new files.

Here is a screenshot:

image description

This problem is really frustrating, not only when editing, but also when trying to use the Presenter Console during a presentation, as I can't see what's coming next!

The problem crops up if I paste formatted text from any other application, and the result is always the same. I can't find anything in my settings to enable or disable this "feature".

The info to enable this setting seems to be stored in the file itself, as other programs, such as Calligra Stage, preserve it.

Use default formatting does not fix the problem.

Here is a screenshot of what the text looks like while editing the text: image description

And when not editing:
image description

Sample file:
https://www.dropbox.com/s/gbguahfktmd...

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-21 23:04:01.944872

Comments

The sample file is helpful. With your sample file I see the problem in a LO daily build, but I do not see the problem in LibreOffice 4.2 and not in Apache OpenOffice. Which version do you use? When I resave the attached file in AOO and then open it in the LO daily build, it is OK there too. Have you already searched bugzilla, whether a special build has such problems?

Regina gravatar imageRegina ( 2015-06-06 01:44:23 +0100 )edit

I have the same problem, it's only shown up since the upgrade to 4.4

labarna gravatar imagelabarna ( 2015-06-22 23:24:53 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-06-05 15:53:24 +0100

Regina gravatar image

Yes, the pasted text has unsuitable color information. Solution: Do not insert it with Ctrl-V, which takes the formatted text from the clipboard, but use the item "unformated Text" from the drop-down-list of the "Paste"-button or from the "Paste Special"-dialog, which you get via menu Edit or shortcut key Ctrl-Shift-V, or use Ctrl-Alt-Shift-V to insert it directly as unformated Text.

For already existing white backgrounds you need to correct each of them manually (or per macro). Select all the text in the box (not the box itself) and apply "Default Formatting" from the menu Format.

edit flag offensive delete link more

Comments

This doesn't fix the problem. Furthermore, once it happens on one slide, it affects all other slides. Text boxes are unaffected, only subtitles and titles.

Roland Taylor gravatar imageRoland Taylor ( 2015-06-05 18:41:43 +0100 )edit

Then it is likely this bug https://bugs.documentfoundation.org/s...

Regina gravatar imageRegina ( 2015-06-23 21:38:53 +0100 )edit
0

answered 2015-08-25 19:48:05 +0100

jlp gravatar image

Open and Libre Office user for many years, I confirm that this incredible bug is still present in version 4.4.3.2 and occurs when you paste text from an other Libre Office file. The bug may easily turn people crazy because there is no way to manually change the text format BUT you can get easily back your presentation, just save your file in PPT format and then open it again !

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-06-04 22:58:06 +0100

Seen: 2,416 times

Last updated: Jun 05 '15