Ask Your Question
1

Slow typing response in in larger documents

asked 2015-06-11 07:48:13 +0200

DanielS gravatar image

updated 2015-09-27 18:31:53 +0200

Alex Kemp gravatar image

Hi ya,

I'm running LO 4.4.3.2 on Win 7 64 bit SP1. I have a growing English, Ancient Greek document I'm working on. Typing in English is met with very slow feedback. I easily outrun the typeahead and wait to see what typos I've made. The document contains 49000 words, 270000 characters approximately and no images. I would not have thought this was especially big. I have no images in it. It is alternating Greek and English chunks. The Greek is pasted in and then I type my translation in English. I have played with various things like the memory options (despite it being a problem for images), auto correct options, plugins and nothing has made a difference. The alternating chunks are styled differently but that's about all.

Any thoughts or suggestions as to what I might try ?

Thx D

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-06-11 16:07:25 +0200

DanielS gravatar image

Thanks for your response. I tried turning off autosave and that made no difference. But I think I may have just found the issue. One thing I forgot to mention is that the document has many comments annotating various bits in the text. They are normally displayed. If I uncheck the View -> Comments checkbox there is no typing lag. If I turn it back on there is.

This sounds like a bug to me. I don't know if anyone else has noticed this. I'll do a search of the KB now.

Thx D

edit flag offensive delete link more

Comments

Hi - This will not solve your problem but in the meantime, for information, the comments bar can be easily toggled with the button in the ruler (faster than going through the menu but not displayed in zoom optimal view). HTH.

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-11 17:17:34 +0200 )edit

Hi Daniel

Thanks for the feedback. It may well save someone else some grief. I'm glad that you found it.

Alex Kemp gravatar imageAlex Kemp ( 2015-06-11 17:20:14 +0200 )edit
0

answered 2015-06-11 13:28:59 +0200

Alex Kemp gravatar image

The doc I'm currently working on (LO-4.4.3.2 under Debian 6.0) is 74,800 words, 496,084 chars & is sprinkled throughout with much more than just plain-text. I do not suffer the problems that you report. Except under one situation:-

Auto-Save:- (menu): Tools - Options - Load/Save - General

Previously auto-save was set to default values (10 minutes?). I've changed that to 30 minutes & it still seems to affect the document more frequently than that. There is a little utility on my system that shows live system load, and it indicates that Processing for save begins a minute or two before the document is actually saved. When that cpu activity begins the LO screen becomes unresponsive and, of course, during actual save is the same. That may be one reason for your issue.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-06-11 07:48:13 +0200

Seen: 1,874 times

Last updated: Jun 11 '15