Ask Your Question
0

Upgrade from LO 4.2 to 4.4 breaks + crashes on Ubuntu 14.04

asked 2015-06-15 22:12:34 +0200

CBhihe gravatar image

updated 2015-08-24 18:18:12 +0200

Alex Kemp gravatar image

I had a small apparent prbm using LO Writer 4.2 on an Ubuntu 14.04.2 OS running fine on all counts. I filed a bug thinking this might be the best way to improve the LO package. When my bug was first triaged, I was immediately advised to update to 4.4. I did and all hell broke loose. Now I cannot run LO, much less use it at all.

Using LO writer messes with my video, first on the screen where its window appears. If I go from one screen to the next if only with my mouse pointer, the second screen sems to be contamined from the giberrish that moves about on the first one. Then all the system slows down to a definitive freezes. This is the first time that I see Ubuntu freeze at all and not for lack of use on my part in the past 15 months. Only solution is cold reset by pulling the plug on my machine (HP 8510w with a brand new GPU in it). Only one document can open at any one time; it does so very slowly. When all the pages are eventually loaded (as shown by the page count in the lower left corner), if I try to open a second one, LO Writer exits instanteously and leaves a document to be recovered behind.

The pbm with which this update mess originated was that when LO Writer 4.2 loaded extra large doc (more than 200 pages of texts containing quite a few hyperlinks and one very large table with a great number of notes at end of document, punching in CTRL+F [keyword(s)] Enter would make the window go dark and freeze indefinitely if all the pages had not finished loading. Because that behavior was absolutely systematic and happened on all large documents, I thought there might be a execution conflict between loading and parsing the CTRL+F [keyword] ENTER command. So I filed a bug and followed the advice I received.

Now I have a completely unusable LO on my desktop. I'd love to go back to 4.2 or better yet to have 4.4.3.2 work. I have tried uninstalling , reinstalling. The result is always the same: a big fat mess made everytime LO 4.4 opens a doc and plays havoc with video.

Can anybody help ? Tx. -ced

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-06-16 16:37:50 +0200

CBhihe gravatar image

@Alex Kemp: Thanks much for the attention and advice. For the sake of the LO-bug triage person who advised on updating, and although he/she did not provide any detail of cautionary remarks on the update process, I SHOULD have known in advance not to jump ahead of myself and updated without carefully purging all of my previous LO 4.2.x install. I had removed the previous install but had left behind a number of to-date-unidentified config files. Additionally (still to the credit of my LO-bug-triage helper who could not know that only a tiny portion of my brain worked at the time, I went on to use the excellent Synaptic package manager for the first time ever, instead of relying on my usual good-for-noobs Ubuntu software center (USC). The result is I casually loaded modules that, although all related to LO, could not coexist without making it look like my machine's GPU was experiencing imminent meltdown.

So ! I force purged everything, was very thorough in that, read quite a few wikis and visited countless dev pages to check on every basic module I might be interested in. In the end it all came to removing a couple of KDE related modules that got in the way of the pure Gnome integration module for LO 4.4.3.2. My LO install is now usable. So CASE CLOSED !

PS: I still have one nagging problem and it is that I cannot write diacritical from my ES-international keyboard as before in LO. It does work everywhere else on my platform but not in any of LO's modules. For instance: combining ' and e become normally é; 'i becomes ï; "u become ü, etc. It may be that I am missing a new option setting or something simple. I will post a separate question about that.

edit flag offensive delete link more
0

answered 2015-06-16 09:39:19 +0200

Alex Kemp gravatar image

Hi CBhihe

I currently work on a 482 page doc under Debian 6.0 using LO-4.4.3.2 (fresh install on all counts). I've got strong complaint about many aspects of it's operation, but nothing like your situation.

Re update advice: I used to provide Internet & Network support. Whenever someone says something like "update to fix that problem" ask "Why?". If they cannot give you chapter & verse on how updating xyz is relevant to your problem on your system, ignore them.

The one piece of advice that you are going to receive constantly is to re-start with a clean profile. This is a bit like "update to 4.4", but it clearly comes about because corruption in the profile can cause all sorts of problems. I am unable to help with the location(s) under Ubuntu (I'm a Debian novice), but a quick search should fix that. It should be a simple matter of re-naming a directory.

One clear bug-chase effort could be to search out a version of your OS available for a USB-stick as a "Live install". Boot up with that on the same hardware, install (or update to) same version LO--which should be memory only--& see if the problems repeat:-

  • Yes: the problem lies solely with LO & you can give them a real rocket
  • No: the problem is within either your computer (hardware issue) or OS (driver/config) or LO (setup/config).

Good luck.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-06-15 22:12:34 +0200

Seen: 303 times

Last updated: Jun 16 '15