Ask Your Question
0

Calc Scenarios Export to PDF creates extra pages with Scenario fields

asked 2015-06-21 09:56:46 +0200

PeterLairo gravatar image

updated 2015-08-25 14:42:05 +0200

Alex Kemp gravatar image

Calc Scenarios Export to PDF creates extra pages with Scenario fields

I have a calc spreadsheet that uses scenarios (under: Tools / Scenarios). Also, the footer has page numbers. When I export the spreadsheet to PDF (via File / Export as PDF), Calc creates the PDF file with an extra page for each scenario. It also numbers the pages so that the scenario pages are also counted (the "Total Pages" number is wrong / too high). So, instead of getting "Page 1 of 5", Calc creates "Page 1 of 25" (when there are 20 Scenarios).

I can delete the unwanted scenario pages in the PDF file, but the incorrect page numbers cannot be fixed. Is this a bug, or is there a way to prevent Calc from creating additional pages for the Scenarios?

edit retag flag offensive close merge delete

Comments

Please what is your LibreOffice version?

m.a.riosv gravatar imagem.a.riosv ( 2015-06-21 12:41:44 +0200 )edit

LibreOffice 4.4.3.2 ("Fresh" branch) (on Windows 7)

PeterLairo gravatar imagePeterLairo ( 2015-06-21 15:31:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-21 13:27:40 +0200

pierre-yves samyn gravatar image

Hi

Creating sheets by the Scenario tool is not a bug but normal feature, even if you uncheck the options Copy backand Copy Entire sheet when created (these sheets are hidden by default).

To not print (or export) just set their print area to None: Format Print Ranges Edit Print Range: - None - Total of pages is updated accordingly.

Regards

edit flag offensive delete link more

Comments

All of my Scenarios have "Copy entire sheet" deselected. Therefore, I consider printing/exporting sheets I had chosen to not create a bug.

How do I set the Print Area for the unwanted (hidden) sheets to None? Under Format / Print Ranges / Edit, all I see there is the print range I had defined (basically the part of the Sheet that I want, and Rows & Columns to repeat).

How can I unhide/show these hidden sheets?

PeterLairo gravatar imagePeterLairo ( 2015-06-21 15:16:54 +0200 )edit

OK, I found where to unhide these secretly created unwanted hidden sheets:

  1. Right-Click on the Sheets Tab-bar at the bottom,
  2. Select "Show..." from the Context Menu, and then Shift+select or Ctrl-select all needlessly created hidden Sheets.
  3. Then select each Sheet and select Data / Print Ranges / Clear (yes, you have to do each one separately).

Not a bug my a$$.

PeterLairo gravatar imagePeterLairo ( 2015-06-21 15:27:39 +0200 )edit

Sorry I should have specified how to show these sheets... but you found all alone, well done. Another clarification: you can select multiple sheets and do FormatPrint Ranges

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-21 15:48:29 +0200 )edit

I did try to select multiple sheets and selecting Format / Print Ranges, but the "Clear" Menu-item was not selectable (possibly because one of the sheets already had no Print Range... But which one? Back to doing each one separately...). I still consider LibreOffice's behavior here unwanted (aka a bug).

PeterLairo gravatar imagePeterLairo ( 2015-06-21 15:55:07 +0200 )edit

Yes... that's why I indicated to do FormatPrint RangesEdit (not Clear)

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-21 16:01:18 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-06-21 09:56:46 +0200

Seen: 149 times

Last updated: Jun 21 '15