Ask Your Question
0

LO 4.4.3.2 -> English Sentence checking is missing on Linux

asked 2015-06-25 09:22:28 +0200

xyTo gravatar image

updated 2015-08-24 23:55:39 +0200

Alex Kemp gravatar image

Hi,

I am using LO 4.4.3.2 on two machines. A WIN7 x64 where I have recently upgraded from 4.3.x to 4.4.x. I was very happy to see the new spell checking capabilities regarding grammar and decided a few weeks later to use the stable ppt of the 4.4 branch to upgrade my LibreOffice 4.3 on my Ubuntu machine too.

However, the new section in TOOLS>>OPTIONS>>LANGUAGE SETTINGS called ENGLISH SENTENCE CHECKING is not present on the Ubuntu installation. The Linux installation seems to miss a module in WRITING AIDS in the Available module section named "Lightproof grammar checker (English)" as well, which is situated just below the Hunspell module on Windows (but not Linux). Now I was hunting for this plug-in on the LibreOffice section but was not able to find any.

Opening the extension manger on the win LO version I have an extension called "English Spelling dictionaries, hyphenation rules, thesaurus and grammar checking" in version 2011.12.05.1. Opening its preferences presents exactly the same options as in the new spelling section ENGLISH SENTENCE CHECKING.

Does anybody now where to get this for LO 4.4.x for Linux and how to install it?

Thanks a lot for your help!

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2015-06-26 10:07:23 +0200

xyTo gravatar image

updated 2015-07-02 08:46:09 +0200

Hi,

thanks for the quick reply.

I am running on Ubuntu 14.10 utopic EN

My current LO version is 4.4.3.2 EN

it was installed over 4.3.7 via the official LO repository (libreoffice/libreoffice-4-4) by:

sudo add-apt-repository ppa:libreoffice/libreoffice-4-4

followed by

sudo apt-get update && sudo apt-get dist-upgrade

no errors occurred, all went fine.

@peter: I have no LibreOffice folder in \OPT\

However, I discovered:

/usr/lib/libreoffice/share/extensions/

It contains only one file named "package.txt"

I would very much appreciate if I could stay away from manually downloading and installing anything and rather help fixing the ppa since this is one of the reasons for me to work with Linux - things are updated automatically!

Thank you for your help!

UPDATE 2015-07-02: I have contacted the LO launchpad team about this issue https://launchpad.net/~libreoffice

edit flag offensive delete link more
0

answered 2015-06-25 11:58:53 +0200

Alex Kemp gravatar image

I'm using 4.4.3.2 under Debian 6.0, downloaded LibreOffice_4.4.3_Linux_x86_deb.tar.gz from the LO site & have exactly as petermau has already laid out. If you obtained LO via a Repository then YMMV.

edit flag offensive delete link more
0

answered 2015-06-25 10:23:19 +0200

petermau gravatar image

updated 2015-07-02 14:03:35 +0200

I came across the following answer when I search the Internet for "LibreOffice ENGLISH SENTENCE CHECKING". This seems to be helpful for our problem. I did not meet it when downloading directly the English/French and Spanish versions from the Document Foundation site. For some reason it appears that the dictionaries are not downloaded with LibreO on UBUNTU. http://askubuntu.com/questions/525544...

The dictionary files for LibreOffice in Ubuntu are held in the \OPT\LibreOffice 4.4\share\extensions folder. There should be dict-en, dict-fr and dict-es. These extensions are included in the base system. My versions of 4.4 and 5.0 downloaded from the Document Foundation site contain these extensions and provide me with the functions you say are missing from your Ubuntu system. What version of Ubuntu are you using, what version of Libre-Office and language, and how did you download and install the package. The more information you give the more easily someone might be able to help....Peter

Some additional thoughts.You can check that the English dictionary has indeed been downloaded and installed by using say SYNAPTIC and search for libreoffice4.3-dict-en (adjust for version of LibO) There is a different version for 4.3, 4.4, 5.0 etc. And make certain that you you have an installed dictionary selected. TOOLS > OPTIONS > LANGUAGE SETTINGS > LANGUAGES and the language selected has a tick against it. Some installations of LibO do not load all the bells and whistles.

edit flag offensive delete link more

Comments

Hi Peter,

I have only noticed your your addition today - I have not realized that one can only have one comment and has to edit it. (Though I like this!) I have been checking once more TOOLS > OPTIONS > LANGUAGE SETTINGS > LANGUAGES and all is fine. I have a blue tick in front of the spell correction. BTW, spell correction is working fine. It is ENGLISH SENTENCE CHECKING I am missing. I believe I could install this if I would find a source for this add-on but I cannot...

see my updated post.

xyTo gravatar imagexyTo ( 2015-07-02 08:43:24 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-06-25 09:22:28 +0200

Seen: 367 times

Last updated: Jul 02 '15