Ask Your Question
0

Howto correctly display imported fonts from Windows?

asked 2015-06-27 09:33:57 +0200

mackowiakp gravatar image

updated 2015-08-25 07:53:04 +0200

Alex Kemp gravatar image

My LO version 4.4.2.2-4, Polish language both Libre Office and system, installed on Mageia 5 Linux 64 bit version both LO and system. Libre Office installed from Mageia repo. I imported Microsoft fonts from WIN 8.1 partition installed on the same HDD. All imported MS Fonts are presented correctly under system. The most imported for me are Arial and Times New Roman. I check it, it is possible to use such fonts in Thunderbird while creating emails in HTML format. Font viewer build in system, presents all imported fonts correctly. But in all Libre Office apps (for example Writer) national character of my language ale presented as square and spaces too. What can I do to repair such situation?

edit retag flag offensive close merge delete

Comments

I added answer to my question with necessary infos for You

mackowiakp gravatar imagemackowiakp ( 2015-06-27 12:25:13 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-06-27 10:50:48 +0200

Alex Kemp gravatar image

Hi mackowiakp

I cannot assist with why you are getting `square & spaces' (it may help if you can describe your problem more accurately), but let me reassure you about the Microsoft fonts:- M$ made most of it's core fonts freely available in 1996 (try searching in your repo for 'mscorefonts' - that will include Arial + Times New Roman) + & they tend therefore to get auto-installed on most Linux systems. In addition, M$ Vista-specific fonts are available together with the PowerPoint Viewer 2007 download from M$. If both the fonts & Writer are individually correctly available for your user then everything should "just work".

One thing that you can investigate is via menu: Insert Special Character..., which will allow you to look at all the tables of characters available for each font.

Final thing to try:- what value do you get in a Terminal with 'locale'?

alexK@AVLinux:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=en_GB.UTF-8
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
edit flag offensive delete link more

Comments

I added answer to my question with necessary infos for You

mackowiakp gravatar imagemackowiakp ( 2015-06-27 12:26:29 +0200 )edit

Problem resolved! Using command: find /usr/share/fonts/ -type f -exec rpm -qf {} + | sort -u I found all font files that not belongs to any Mageia package. And removed it. Now it works OK !!!

mackowiakp gravatar imagemackowiakp ( 2015-06-27 13:40:07 +0200 )edit
0

answered 2015-06-27 12:07:57 +0200

mackowiakp gravatar image

updated 2015-06-27 12:35:38 +0200

OK. As a attachment is screen shot of "square & spaces'" I wrote about

Upps. I am beginner on this forum so I can not add attachment. So link to Dropbox with screen shot:

https://www.dropbox.com/s/xm9vfzh3600...

And output from locale command

 bash-4.3$ locale
 LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

An as I wrote, system and other apps like GIMP, shows fonts properly. The problem is only in Libre Office. So it is strange for me. I try to reinstall LO but without positive results. I really don know what to do.. HELP please!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-06-27 09:33:57 +0200

Seen: 319 times

Last updated: Jun 27 '15