Ask Your Question
0

In Calc, when I auto filter date, June, all June plus 6th of all other months appear. Why?

asked 2015-07-06 07:43:11 +0200

mihikatha gravatar image

updated 2015-08-24 17:05:33 +0200

Alex Kemp gravatar image

Hi Lupp, Thanks for your support. Here is the File (Part). Hope this would do.

Expenses15.ods

OS is Ubuntu 14.04

edit retag flag offensive close merge delete

Comments

Please attach a relevant example document demonstrating the issue. From what you wrote I cannot even conclude whether your "dates" are actual dates (numerical values with a specific format applied) or whether they are text. Most likely you work in an US locale where dates formatted regarding the local usage are in conflict with international standards.

Lupp gravatar imageLupp ( 2015-07-06 12:15:04 +0200 )edit
1

Just a casual observation as I have not used auto filter: June is the 6th month of the year. Is your filter entered ambiguously?

JKEngineer gravatar imageJKEngineer ( 2015-07-07 01:08:40 +0200 )edit

Hi Lupp, Here are some data from my File (Date field included).

EDate Item 1 Jan 15 00 1 Jan 15 00 2 Jan 15 51 2 Jan 15 53 3 Jan 15 01 3 Jan 15 02 3 Jan 15 40 3 Jan 15 62 3 Jan 15 68 3 Jan 15 71 5 Jan 15 62 6 Jan 15 40 7 Jan 15 70 8 Jan 15 40 8 Jan 15 51 10 Jan 15 02 10 Jan 15 40 10 Jan 15 70 11 Jan 15 53

mihikathaj

mihikatha gravatar imagemihikatha ( 2015-07-14 17:04:24 +0200 )edit

Hi Lupp, This is the only way I know. I don't know, how to attach documents.

mihikathaj.

mihikatha gravatar imagemihikatha ( 2015-07-14 17:07:36 +0200 )edit

Sorry. Data pasted into the editor here are always text and won't help to find out something abot your sheet.

If you edit the question you will be offered some iconized tools above the editing window. The paperclip clicked will start the attachment tool.

Lupp gravatar imageLupp ( 2015-07-14 18:19:10 +0200 )edit

autofilter does not seem to do anything useful on Linux LO 5.0.0.2. That said, consider whether the Locale settings at Tools-->Options-->Languages-->Locale setting affect your situation. The dates in your sheet appear to be in European d/m/y rather than US format.

doug gravatar imagedoug ( 2015-07-15 17:32:29 +0200 )edit

@doug

autofilter does not seem to do anything useful on Linux LO 5.0.0.2.

Care to elaborate? Work fine for me.

erAck gravatar imageerAck ( 2015-07-15 17:51:47 +0200 )edit

I press the button, it does not filter results by hiding anything. This does not seem to be consistent with the documentation, but I have not tried that feature before so I might just misunderstand it.

doug gravatar imagedoug ( 2015-07-15 22:29:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-07-15 17:57:26 +0200

erAck gravatar image

updated 2015-07-15 18:07:47 +0200

I noticed the dates are formatted to an English (Australia) locale. If I start LC_ALL=en_AU soffice then filtering on June works fine, if I start LC_ALL=en_US soffice then I get the faulty behaviour you described. Apparently a bug.

Bug submitted as https://bugs.documentfoundation.org/s...

edit flag offensive delete link more

Comments

And fixed.

erAck gravatar imageerAck ( 2015-07-21 13:04:09 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-07-06 07:43:11 +0200

Seen: 150 times

Last updated: Jul 15 '15