Ask Your Question
0

importing csv files to a Base table

asked 2015-07-29 11:52:40 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I copy the calc csv file open the dBase table edit and paste the data, it loads into the first column and row only what am I missing out of the process

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2015-07-29 13:09:52 +0200

Regina gravatar image

Do not copy&paste, but save the Calc spreadsheet table directly as dBase-table (*.dbf) into the folder which makes up your dBase data base. During "Save Copy as" you can select the character encoding. I would choose the same as in the other dBase-tables. Make sure, that the Calc spreadsheet table has the structure of a database table, with the first row of the containing strings, which are suitable as dBase field names. You need not add the formatting, it will be detected automatically if there exist enough rows with data.

edit flag offensive delete link more

Comments

@Regina said that you should not Copy & Paste but following this method of saving as .dbf does not cause the Table to appear in the database. You still have to open the .dbf file (it opens in Calc), copy and paste into the database. Or is there another way to get the .dbf into the Database?

peterwt gravatar imagepeterwt ( 2015-07-29 15:51:20 +0200 )edit

As dBase was mentioned, I have assumed, that the database file has been already generated. The database type "dBase" in LibreOffice takes a folder as database and should show all .dbf files inside this folder as tables. That does not work for you? You have used "Connect to an existing database" with item "dBASE"?

Regina gravatar imageRegina ( 2015-07-29 16:37:38 +0200 )edit

@Regina I assumed that the poster @robertw was referring to a LO Base database!!

peterwt gravatar imagepeterwt ( 2015-07-29 23:39:03 +0200 )edit
0

answered 2015-07-29 15:09:37 +0200

peterwt gravatar image

updated 2015-07-29 15:42:44 +0200

Copying a csv file containing Table data works for me. Make sure that when you copy the csv you "Select All" otherwise you will only copy the first cell in the spreadsheet which looks like what you found. When pasting you should see all of the field names - select them all. As @Regina said the first row of the spreadsheet must contain the field names.

edit flag offensive delete link more
0

answered 2015-07-29 20:51:06 +0200

robertw gravatar image

Thank you for the answers will try again Is there a preferred character encoding in LO?

edit flag offensive delete link more

Comments

Thanks Regina saving the csv file as a .dbf opening dbase folder (registered) selecting edit - paste - created the table simple! The data now usable for labels, mailmerge, sales funnel etc. Made my day

robertw gravatar imagerobertw ( 2015-07-30 08:59:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-07-29 11:52:40 +0200

Seen: 3,990 times

Last updated: Jul 29 '15