Ask Your Question
0

Writer. Keep with next paragraph problem

asked 2015-07-29 23:12:51 +0200

LG gravatar image

updated 2015-08-23 23:25:17 +0200

Alex Kemp gravatar image

Hi, the text I'm writing had some unexplainable page interruptions. I thought I could resolve it by unchecking "keep with next paragraph". This solves the problem only until I open the file again (obviously after saving it). And "keep with next paragraph" appears as checked again, too. I searched a lot online and I really don't know how to solve this.

Libre Office version: 4.3.7.2 S.O. Windows 7.

Thank you

lorenzo

edit retag flag offensive close merge delete

Comments

This problem drove me crazy.

The reason why you need it saved in .docx is because you're collaborating on the document with other users who are using Word.

The solution is, the other users have to uncheck "keep with next paragraph" too, through Word, or you uncheck it yourself, but on Word, not just on LibreOffice. If they don't uncheck it too though, it might be the case that the problem will reappear.

pekingduck gravatar imagepekingduck ( 2017-09-25 12:05:46 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2015-07-29 23:54:02 +0200

Alex Kemp gravatar image

"Keep with next paragraph" is designed to prevent 'Widows & Orphans" (singles lines from a paragraph at the beginning/end of a page). If you are certain that this is not at play in this case, then you have the characteristic wierd-problem-that-should-not-be-happening-but-which-has-a-single,-simple-fix:-

A corrupt profile can cause such problems. Fortunately, it is easy to fix (and to reverse):

Re-Setting the User Profile:

  1. Close down LO/OO + the Quickstarter
  2. Go to your profile
  3. Rename the folder
  4. Restart the program
    (this re-creates a default Profile)
  5. Restart LO & try again

If this helps then please tick the answer (✔).

edit flag offensive delete link more

Comments

Anyone is capable of solving this? I had to switch to Microsoft Word!!!

LG gravatar imageLG ( 2015-08-10 19:05:21 +0200 )edit
0

answered 2015-07-30 10:37:18 +0200

LG gravatar image

Thank you Alex. I renamed the folder with my user data. When I restarted Libre Office then it appeared as cleaned by my personal settings. Then I opened the file, which initially presented the same interruptions problem. I then unchecked "keep with next paragraph". I saved. When I opened the file again, unfortunately, the problem was there again. I think I should add an important element I forgot to mention: I have to save the file in docx.

lorenzo

edit flag offensive delete link more
0

answered 2015-07-30 10:53:12 +0200

pierre-yves samyn gravatar image

updated 2015-07-30 11:07:36 +0200

Hi

I reproduce your problem on windows 7 & LibreOffice 4.4 (and save to docx)

The workaround is to clear direct formatting (Ctrl+M) of the paragraph instead of simply uncheck keep with next paragraph. Of course this also delete other direct modifications to the style.

Regards

edit flag offensive delete link more

Comments

Thank you Pierre. I gave your solution a try. But it doesn't work. If there's anyway to upload a file here? I just pasted and copied the first two paragraphs of my file to another file (I changed all the words like "word word" etc...). The new file has the same problem, so it is available for anyone who wants to look at it.

LG gravatar imageLG ( 2015-07-30 23:35:57 +0200 )edit
0

answered 2017-09-25 12:06:26 +0200

This problem drove me crazy. The reason why you need it saved in .docx is because you're collaborating on the document with other users who are using Word. The solution is, the other users have to uncheck "keep with next paragraph" too, through Word, or you uncheck it yourself, but on Word, not just on LibreOffice. If they don't uncheck it too though, it might be the case that the problem will reappear.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-07-29 23:12:51 +0200

Seen: 1,179 times

Last updated: Sep 25 '17