Ask Your Question
0

Why are there no icons/images in LibreOffice help browser?

asked 2015-08-11 14:01:39 +0100

muhammad muneeb ejaz gravatar image

updated 2015-08-27 12:18:37 +0100

Alex Kemp gravatar image

Whenever i open help inside libreOffice from menu-bar, text displays correctly but no icons appear or image appear in the help window instead "vnd.sun.net" appears inside the box. I have used both windows and ubuntu version and both don't display images or icons. Any idea how to fix it or it is not a problem at all?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2017-03-15 11:07:24 +0100

Librai gravatar image

updated 2017-03-15 11:10:43 +0100

The mentioned suggestion did not work for me (Libreoffice Version: 5.1.6.2, Build-ID: 1:5.1.6~rc2-0ubuntu1~xenial1, OS: Version Linux Mint 18.1 Serena 64-bit, Kernel Linux 4.4.0-66-generic x86_64, MATE 1.16.1).

I also installed an activated additional styles like Galaxy, Sfir, Breeze, Tango, Human (restarted LO each time). I found this bug report which looks similar to my issue and I followed the instructions here

In help window some small icons are displayed as expected. They have a "file/path name" is like: vnd.libreoffice.image://galaxy/cmd/sc_helpindex.png

But bigger images are only displayed as frame with name (eg. Tippsymb) inside. Those have "file/path names" are like: vnd.libreoffice.image://galaxy/res/helpimg/tip.png

I have also checked

librai@tipa /usr/lib/libreoffice/share/config $ ls -l
insgesamt 20
lrwxrwxrwx  1 root root   60 Feb 23 01:24 images_breeze.zip -> ../../../../share/libreoffice/share/config/images_breeze.zip
lrwxrwxrwx  1 root root   60 Feb 23 01:24 images_galaxy.zip -> ../../../../share/libreoffice/share/config/images_galaxy.zip
lrwxrwxrwx  1 root root   59 Feb 13 19:33 images_human.zip -> ../../../../share/libreoffice/share/config/images_human.zip
lrwxrwxrwx  1 root root   58 Feb 23 01:24 images_sifr.zip -> ../../../../share/libreoffice/share/config/images_sifr.zip
lrwxrwxrwx  1 root root   59 Feb 23 01:24 images_tango.zip -> ../../../../share/libreoffice/share/config/images_tango.zip
drwxr-xr-x 17 root root 4096 Dez 13 11:27 soffice.cfg
drwxr-xr-x  2 root root 4096 Mär  1 08:27 webcast
drwxr-xr-x  4 root root 4096 Dez 13 11:15 wizard

What am I missing in my installation? How can I fix it?

Thanks in advance

Librai

edit flag offensive delete link more

Comments

There had been problems with images in help files. But now we are one and a half year later and a lot of bugs in regard to the help are fixed. So you should use the current mature version 5.2.6.

Regina gravatar imageRegina ( 2017-03-15 18:13:22 +0100 )edit
0

answered 2015-08-23 21:34:59 +0100

Regina gravatar image

Goto Tools > Options >LibreOffice > Security > Security options and warnings> button Options.... Uncheck the option Block any links from documents not among the trusted locations (see Macro Security). If that helps, then you are hit by bug tdf#81091.

If not all images in help are missing, but only some, then it is likely a problem of the used icon set. In that case try with icon set "Galaxy". To change the icon set goto Tools > Options > LibreOffice >View, and select it below item Icon size and style.

edit flag offensive delete link more
0

answered 2015-08-23 08:41:07 +0100

Alex Kemp gravatar image

I do not know if it is a problem, but it is damn irritating!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-08-11 14:01:39 +0100

Seen: 819 times

Last updated: Mar 15 '17