Ask Your Question
1

Install version 5. Do I need to uninstall version 4 first?

asked 2015-08-12 23:03:08 +0100

LibreGuy gravatar image

updated 2015-08-22 22:06:12 +0100

Alex Kemp gravatar image

Hi guys,

My current LibreOffice version is 4.4.4.3

I see there is a version 5 now. I would like to install it. Do I need to uninstall version 4 first? Or will this be done automatically?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-08-12 23:45:17 +0100

Lupp gravatar image

updated 2015-08-13 08:13:07 +0100

Version 5.0.0 is very fresh and I wouldn't advise to use it "in production". On my Win system it (the 64-bit V5.0.0 RC5) installed without a problem while the 32-bit 4.4.4 was left untouched in its location. V5 assigned itself as the default software to open all the acceptable document types and continued using the old user profile. No problem - except that we may some time want to delete the old program folder.

Editing: Some of my remarks (now struck) were not correct. (See my second comment below.)

edit flag offensive delete link more

Comments

Thanks for replying. Why wouldn't you advise to use it in production? Does it contain bugs or something? As I understand you correctly the version 4 folder wasn't automatically deleted. Can I just delete it afterwards then?

LibreGuy gravatar imageLibreGuy ( 2015-08-13 00:16:48 +0100 )edit

Every complex soiftware is containing bugs by the thousands. It's a question of severeness and of escaping by thorough use.. I sometimes experience a bug which was present for years, but didn't become noticeable to me for a long time. A new first-digit-version will come with some new features. Code will be rewritten for one or another reason. There may occur new bugs or regressions an there wasn't a lot of time to find and fix them. (In this case we dare hope as 5.0 is somehow 4.5 renamed.)

Lupp gravatar imageLupp ( 2015-08-13 07:58:41 +0100 )edit

Deleting the version-4-program-folder should be safe. I have to correct myself: Most of the content of the V4-folder was deleted already by the V5 installation.

Lupp gravatar imageLupp ( 2015-08-13 08:07:18 +0100 )edit

Think again about the "V4-folder". 5.x uses the identical folder/directory as 4.x (how wonderful).

Alex Kemp gravatar imageAlex Kemp ( 2015-08-13 08:17:51 +0100 )edit

This is only the case for the user profile, still appearing in 'AppData\Roaming\LibreOffice\4' of the user section. Under Win 8.1, at least, the program folder for the 64-bit version is now named 'LibreOffice 5', and (correctly) placed under 'Program Files' instead of 'Program Files (x86)'. (Didn't test: Maybe the installer will create a \5 user profile if no \4 profile is present.)

Lupp gravatar imageLupp ( 2015-08-13 09:24:07 +0100 )edit

LO 5 is nice, but at this time I agree it is not yet mature enough for production use, esp. concerning Base. Encountering larger number of anomalies and crashes.

doug gravatar imagedoug ( 2015-08-13 17:19:24 +0100 )edit

I don't use base. I mainly use Writer and Calc. So far no problems ... hope it stays like that.

LibreGuy gravatar imageLibreGuy ( 2015-08-13 17:33:58 +0100 )edit
0

answered 2015-08-13 16:54:49 +0100

LibreGuy gravatar image

updated 2015-08-13 16:56:47 +0100

Well, I just installed LibreOffice 5. Everything still seems to be working fine :-)

The LibreOffice 4 folder in "Program Files" was perfectly deleted by itself. The roaming data was preserved in the "old" LibreOffice 4 folder and all of my settings were maintained. So far, everything looks good!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-08-12 23:03:08 +0100

Seen: 1,726 times

Last updated: Aug 13 '15