Ask Your Question
0

Fedora 22 upgrade, spell check not working

asked 2015-08-19 15:53:25 +0100

marcus hall gravatar image

updated 2015-08-23 23:37:17 +0100

Alex Kemp gravatar image

I have upgraded several systems to Fedora 22 (Libreoffice 4.4.5.2) and have now discovered that the auto spell checking is no longer working. That is, a misspelled word used to get a red squiggled line under it and produce suggestions on the correct spelling.

One suggestion that I have seen is to re-set the default language to "English (USA)". For some of the systems, this has worked and auto spell check is working, but on other systems this seems to not be working.

On the systems that are not working, the pull-down list showing all of the available languages shows an icon that looks like "ABC" and a check next to all of the english options EXCEPT for "English (USA)". On the systems that are working, this icon is present only on the "English (USA)". I interpret the icon to indicate that spell checking is available for these languages, and indeed, if I select "English (UK)" or any other choice with the icon, I do get auto spell checking.

I did see mention of installing "libreoffice-langpack-en". There were no language packs installed initially. After installing this, however, the situation has not changed.

So, the question is, how did I get all variations of English enabled for spell checking EXCEPT for USA, and, more importantly, how do I fix it?

Thanks!

marcus hall marcus@tuells.org

[Edit: added lo4.4.5 tag]

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-08-20 20:23:46 +0100

marcus hall gravatar image

OK, I have found what solved the problem for me..

Under Tools->Options->Language Settings:Writing Aids, the list of available language modules showed almost everything set. I unchecked and then re-checked "Hunspell SpellChecker" and "Libhyphen Hyphenator" and hit OK. (I strongly suspect that the hunspell was the significant checkbox). Then, when I go back to Language and look at the default language settings, the "English (USA)" entry has the ABC✔ by it, and now spell checking is working.

Best guess is that some results of invoking something from hunspell is saved by libreoffice and that with updating versions, the cached output is no longer valid. Re-invoking (when re-checking the checkbox) refreshes the cached data and now everything is all better.

edit flag offensive delete link more
0

answered 2015-08-19 18:36:08 +0100

Alex Kemp gravatar image

updated 2015-08-19 18:45:21 +0100

Possibly 2 things to check; inside & outside:

Inside:

  1. Go (menu):ToolsOptionsLanguage Settings
  2. LanguagesDefault Languages for Documents
    Does your choice have a ABC✔ at the left? If not, you will not be able to spell-check the document.
  3. Writing AidsAvailable language modules
    Is the spell-checker listed? (sanity check)
  4. Writing AidsUser-defined dictionaries
    Is your desired language listed + checked?
    If not, go install it (use your Repo, or Online)
  5. Go (menu):ToolsLanguage
    Make sure that the correct language is checked for each of the top-3 (selection, paragraph, all text)
    If (menu):ToolsSpelling & Grammar... also has a ✔ then you are good to go.

Outside:

Resetting the user profile:-

"If you notice any strange behaviour on LibreOffice, or simply it fails to start, the first thing to try is to reset the user profile."

  1. Shutdown LO/OO + Quickstarter
  2. Find your user-profile directory
    (enable 'Show hidden files')
    (note: 5.x profile location is identical to 4.x)
  3. Rename it
  4. Restart LO/OO

...and try again.

LO/OO is very prone to Profile Corruption. In the absence of an existing profile it is designed to re-create a new, default profile, and that neatly fixes many, many problems.

If this helps then please tick the answer (✔)

edit flag offensive delete link more

Comments

As I had concluded above, the ABC✔ not being present on "English (USA)" is an indicator that spell checking isn't present. But, it is present for the 15 other flavors of english. Why that is so seems to be the root of the issue.

I did rename the ~/.libreoffice directory, but that did not make any difference.

marcus hall gravatar imagemarcus hall ( 2015-08-19 20:31:05 +0100 )edit

Hmm. You renamed the wrong directory.

Your Profile is supposed to be located at (4.x + 5.x):-

~/.config/libreoffice/4/user

(the one you show is for 3.x)
(d/check at:- (menu):ToolsOptionsPaths)

In all cases you rename the /user dir. May not work otherwise.

Alex Kemp gravatar imageAlex Kemp ( 2015-08-19 21:13:17 +0100 )edit

OK, I removed ~/.config/libreoffice and let it re-create things. The old version had a "3" subdirectory and it re-created a version with a "4" subdirectory. Still, no spellchecking on English (USA), just all of the other English (XXX) variations.

marcus hall gravatar imagemarcus hall ( 2015-08-20 15:56:27 +0100 )edit

You had a 4.x installation & it was using a 3.x Profile? That suggests a corrupt install & may also suggest greater problems within that particular system than just LO spell-check issues (although the successful Profile recreation is contrary to that idea).

The most obvious route forward is to clean LO/OO from the system as fully as possible (LO/OO deliberately leaves Profiles in place), check for a sane locale, then reinstall from scratch.

Alex Kemp gravatar imageAlex Kemp ( 2015-08-20 16:30:45 +0100 )edit

I will try removing all of the packages and re-installing in the near future.. Besides the ~/.config/libreoffice directory, what other configuration information is there to remove?

It seems like a system install sort of a problem, since the issue happens for all users on the systems that failed (about 4 out of 5 systems upgraded) and seems to be fine on the one system I know still works. I have verified that all of the packages installed on the working system are installed on the failed......

marcus hall gravatar imagemarcus hall ( 2015-08-20 20:01:08 +0100 )edit

..... systems..

Just what information tells libreoffice which spellcheck dictionaries are installed anyhow? Is there a directory with the databases present, or an XML file somewhere? I suppose that I can compare all files owned by libreoffice packages and see if there is a difference somewhere between the working and failed systems...

marcus hall gravatar imagemarcus hall ( 2015-08-20 20:03:18 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-08-19 15:53:25 +0100

Seen: 1,603 times

Last updated: Aug 20 '15