Ask Your Question
1

No Firebird option LibreOffice 5 Base

asked 2015-08-31 21:19:25 +0200

LKeithJordan gravatar image

updated 2015-09-01 00:11:36 +0200

Alex Kemp gravatar image

Date: 2015.0831

LibreOffice
* Version: 5.0.0.5 (x64)
* Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
* Locale: en-US (en_US)
* LO Component: Base
Operating System
* Windows 7

(I also tried on Linux Mint 17.2 with Cinnamon on a bootable persistent USB stick. For Linux, I used the most recent LO 4.x build that came with Mint 17.2.)


I am a MS-Office power user (including MS-Access), and I am just beginning to experiment with LO as an option or alternative. I have delayed looking at Base because of Java, but I now understand that I should be able to default to (or at least individually specify) Firebird for the database engine. Because I am new to LO, I hope my current problem is simple and that someone can tell me what I am missing.

I am trying to set up LO 5 Base to use Firebird. I have modified the Expert Configuration settings as follows:

  • Preference Name: /org.openoffice.Office.DataAccess/EmbeddedDatabases
  • Property: DefaultEmbeddedDatabase
  • Type: string
  • Value: sdbc:embedded:firebird

On Windows, I have rebooted LO, rebooted the computer, and tried to start creation of a new database, all to no avail. I am also new to Linux, but I tried there as well -- still with no success.

Whether in Tools > Options > Advanced or in Base Database > Create a new database > Embedded database:, Firebird does not show for selection. What am I doing wrong?

edit retag flag offensive close merge delete

Comments

do you also have the firebird database engine installed somewhere? LO long has had the ability to "connect" to an existing Firebird database, and if you had the engine lying around and created a database directly, then LO could connect and control the Firebird database. Can you show the reference you are using for those modifications?

doug gravatar imagedoug ( 2015-08-31 23:58:59 +0200 )edit

No, I don't have the Firebird engine installed. I wondered if I was supposed to download Firebird separately -- but I got the idea that Firebird came with LO 5 (you just had to enable experimental features). Is this incorrect?

As for the modifications, I assume you are referring to the Expert Configuration. Look under the How to Test topic at this link:https://wiki.documentfoundation.org/D...

LKeithJordan gravatar imageLKeithJordan ( 2015-09-01 00:16:10 +0200 )edit

I perhaps should also mention that I did NOT try to edit the content.xml setting inside a new odb (as discussed in the wiki article). I tried to create a new database but stopped when Firebird was not available after I modified the setting via Expert Configuration.

LKeithJordan gravatar imageLKeithJordan ( 2015-09-01 00:27:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2015-09-01 16:31:24 +0200

LKeithJordan gravatar image

updated 2015-09-02 17:31:35 +0200

I fixed it! -- well, sort of.

@m.a.riosv and @doug, thanks for responding. @doug, you gave me an idea and it worked. Here's what I did:

When I went to the official LO download site earlier, I had picked the x64 version (my laptop is 64-bit). You can see from my original post that the LO version I originally downloaded was 5.0.0.5 (x64).

When I went back to the official LO download site, I accepted the default download -- which turned out to be: LO Version: 5.0.1.2 Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261 Locale: en-US (en_US) (this is an x86 version).

After installing, I enabled Experimental features and tried to modify the Expert Configuration. Interestingly, the value for the DefaultEmbeddedDatabase was "Void" and I could not edit the setting.

The same thing happened earlier when I initially tried to edit the version of LO that installed with Mint. As before, I closed and reopened LO after enabling Experimental features and the value changed to "string." I could then edit and set the DefaultEmbeddedDatabase to Firebird.

Firebird still does not display in the Advanced settings window, but now it DOES appear in the listbox as an option when you start to create a new database.

I plan to try a similar approach on the Linux Mint stick, but it seems the install process for the LO download (interestingly, x64) is a bit more involved than for Windows 7 and I'm still a newbie to Linux. I don't have time to complete the install process and test right now, but I'll try to come back and report my findings when I am done.

Since I'm also a newbie on this forum, I don't know the impact of marking this question "answered," so I'll leave it open until I achieve success on Linux.

2015.0902 Update Rather than continue to hold this question open, I will mark the post as answered. Because the only two answers are from me and m.a.riosv, I have added a point to the post by @doug and marked the response by m.a.riosv as the answer to close this question (I hope this is the correct approach). I will open a new question if necessary when I tackle the Linux issue.

edit flag offensive delete link more

Comments

thx, but for technical reasons I suggest you accept your own answer (by clicking the check mark to the left), which you now should have enough karma to do.

doug gravatar imagedoug ( 2015-09-02 17:23:10 +0200 )edit

@doug. I will do as you recommend. All help is appreciated.

LKeithJordan gravatar imageLKeithJordan ( 2015-09-02 17:30:56 +0200 )edit
0

answered 2015-09-01 00:57:05 +0200

m.a.riosv gravatar image

I think you need enable
Menu/Tools/LibreOffice/Advanced - Experimental features.
to have Firebird available.

edit flag offensive delete link more

Comments

Yes, it was as simple as enable those features in main LibreOffice window and then immediately after go to File--> New --> Database and the option Firebird Embedded was on the list as described in the LO 4.2 release notes. The embedded Firebird database did not actually work right away, but the error was a Firebird error so that is a step in the right direction. I uninstalled the stand-alone FB db engine and it worked later.

doug gravatar imagedoug ( 2015-09-01 01:14:41 +0200 )edit

I did enable Experimental features (see my original post).

@doug, as I tried to explain earlier, I did what you describe, but the option Firebird Embedded was NOT on my list. You indicate, however, that you had a standalone version of Firebird on your computer. Do you think that had an impact? I can try to install it on my machine and see if LO Base picks it up.

LKeithJordan gravatar imageLKeithJordan ( 2015-09-01 05:26:23 +0200 )edit
1

no, the stand-alone FB engine might have had a negative impact. At first, my selection of experimental features failed to stick, and was unselected when I returned, so I assumed that was the problem you were having. Try to open in the same session as you select experimental. The reference page also mentions there being different dependencies and build flags for the repository managers, you might see if you can get another source. I am LO 5.0.1.2.0+ OpenSuse 13.2 KDE 5.3.95.

doug gravatar imagedoug ( 2015-09-01 06:08:35 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-08-31 21:19:25 +0200

Seen: 2,930 times

Last updated: Sep 02 '15