Ask Your Question
0

Re-assign Ctrl-+ Ctrl-- as zoom-in/zoom-out shortcut globally

asked 2015-09-02 14:32:59 +0100

Ole Tange gravatar image

updated 2015-09-03 13:27:24 +0100

Alex Kemp gravatar image

I am so used to using CTRL-+ and CTRL-- as zoom-in/zoom-out that it really annoys me when an application does not use these shortcuts. LibreOffice is one that does not.

How can I globally re-assign CTRL-+ and CTRL-- as zoom-in/zoom-out?

edit retag flag offensive close merge delete

Comments

ctrl + mouse pad up/down is the default to do this. I know that this is not an answer to your question, but knowing this satisfied me when I had this same issue :)

lincolnfrias gravatar imagelincolnfrias ( 2016-10-31 17:00:00 +0100 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2015-09-02 21:12:31 +0100

Alex Kemp gravatar image

updated 2015-09-03 13:30:55 +0100

In LO-4.4.4 + LO-5.0.0 you can assign those functions to those keys via the Customise dialog. One of the LO apps needs to be open before you take the steps below:

Step by Step:

  • (menu):ToolsCustomiseKeyboard tab

In Shortcut Keys:-

  • select Ctrl++ (by default assigned to 'Calculate')
  • press Delete button to remove default assignment

In Functions:-

  • select CategoryView
  • select FunctionZoom In
  • press LibreOffice option-button to apply to all of LO
    (else press Writer, or whichever App is open)
  • press Modify button to apply the Function to the Key
  • press OK to apply the shortcut
  • repeat whole sequence for Zoom Out

If this helps then please tick the answer (✔)

edit flag offensive delete link more

Comments

Does not work in Localc/Lowriter 4.2.8.2.

Ole Tange gravatar imageOle Tange ( 2015-09-02 22:00:45 +0100 )edit

Try giving a little more info; it encourage others to want to help you.

As you gave your LO version I added some extra info at the top of my reply.

Alex Kemp gravatar imageAlex Kemp ( 2015-09-03 13:34:17 +0100 )edit

I upgraded to 5.0.3.2. It still does not work. I can set the keys, but nothing happens after I press OK, and press CTRL-+ or CTRL--. I had expected the Zoom percentage in the lower right corner to change, just like it does if I do CTRL-scrollwheel.

Ole Tange gravatar imageOle Tange ( 2015-11-24 17:48:34 +0100 )edit
0

answered 2018-09-16 19:59:25 +0100

BerenErchamion gravatar image

updated 2018-09-17 18:37:38 +0100

the aparent bug is still going in 6.0.5!. found some information about this. there is a bugzilla thread: https://bugs.documentfoundation.org/s... wich states that that the shortcuts you can assing in Tools-customize-keyboard dialog correspond to the preview mode. Browsing the options at Writer: Tools-Cusomize-keyboard-Category=view there are many possibly related Functions. 100%,150%,200%,50%,75%,Optimal,Zoom, Zoom In, Zoom Next, and others. One of the 'Zoom' options acutally opens a zoom dialog that makes it possible to select a zoom level pressing a second shortcut. a shortcut at PageWidth also works. Its not the solution, but this workaround makes the thing workable

EDIT , the day after. in Libreoffice Draw, the following works: https://defkey.com/libreoffice-draw-s... + zooms in - zooms out Num * zoom to fit entire page Num/ zooms to selected object.

to make this work in writer and calc would be of great help. maybe combining the keys with ctrl or super.

edit flag offensive delete link more
0

answered 2017-08-15 19:23:09 +0100

AnthonyC gravatar image

This is still broken in 5.1.6.2.

The shortcut can be modifed but they don't take effect (tried restart application).

edit flag offensive delete link more
0

answered 2017-08-15 21:31:56 +0100

Mike Kaganski gravatar image

This is bug 45705. This is not possible now for Calc or Writer (except for Print preview mode).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-09-02 14:32:59 +0100

Seen: 1,628 times

Last updated: Sep 17