Ask Your Question
0

I cannot update Windows 10 settings to associate .xls and .xlsx file types with LO Calc and cannot receive these file types as email attachments

asked 2015-09-04 05:08:16 +0200

Jim Quinn gravatar image

updated 2015-09-04 11:59:54 +0200

Alex Kemp gravatar image

I cannot update Windows 10 settings to associate .xls and .xlsx file types with LO Calc and cannot receive these file types as email attachments. I am running LO Ver 5.0.1.2 I have windows 10 on an older computer that has OpenOffice and these file types are associated with Open Office Calc such that I can receive emails with these file type attachments.

LO Calc is the default for other file types like .ods

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-09-05 16:53:54 +0200

vsfoote gravatar image

On Windows 10 Pro 64-bit en-US with full installation as Administrator of Version: 5.0.1.2 (x64) Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261 Locale: en-US (en_US)

Have no issue is setting the file association to LibreOffice using Windows 10

Done from Start Menu (the Window lower left) -> Settings -> System -> Default Apps -> "Choose default apps by file type"

Scroll to .XLS or .XLSX and left click. Pop-up dialog "Coose an App" will show applications registered to handle that file type. A LibreOffice icon will show -- but is not labeled (that may be a bug that needs dev attention). Left click to select. LibreOffice icon(unlabeled) now shows as application. Repeat as desired. Close the dialog.

Should now be set. Double click file from Desktop of Windows explorer to test.

edit flag offensive delete link more

Comments

I have gone to "Control Panel>Programs>Default Programs>Set Default Programs>Set Program Associations", picked LibreOffice 5.0, see a message "This program has 103 out of 10 defaults". Pick 1. Set this program as default for all file types and protocols it can open. Pick 2.Choose defaults for this program to see file types that were set to LO. All .xl- items say Unknown App.

Jim Quinn gravatar imageJim Quinn ( 2015-09-10 00:55:21 +0200 )edit

Then I went to Control Panel .....Associate A File Type or Protocol With A Specific Program. I selected .xls which showed Current Default = Unknown Application. I checked it and clicked on "Change Program" which pops up Keep Using This App "LibreOffic Calc" or Other Options...... I picked Keep using LO but nothing changes and I still cannot receive a .xls file type in an email.

Jim Quinn gravatar imageJim Quinn ( 2015-09-10 01:04:56 +0200 )edit

I am now following your instructions and do see the LO icon w/o the LO Calc label. My next test was to go to Outlook on web and try to open attachment. If I pick "View Online" the file is opened but by Excel Online. If I pick Download and then pick Open, it do open correctly with LO Calc. So not LO error. Any idea? Windows 10? Windows Live Mail?

Jim Quinn gravatar imageJim Quinn ( 2015-09-10 01:55:25 +0200 )edit

lThe problem IS NOT that LO Calc is not used to open a file that is stored on my computer with .xls or .xlsx extension. LO Calc is used to open files on my computer with these file types. The problem IS that email attachments with file types of .xls, .xlsx, etc. are blocked in Windows Live Mail on a computer with Windows 10 and Libra Office. However, on another computer with Windows 10, Windows Live Mail, and OPEN OFFICE, these same attachments are NOT blocked.

I don't know what is blocking t

Jim Quinn gravatar imageJim Quinn ( 2015-10-01 04:58:52 +0200 )edit

...continuing ..... I don't know what is blocking the attachments. Is it Win 10, Windows Live Mail, Libra Office, Norton Security? The message about blocked attachments comes from Windows. I am confused because the difference I see in the 2 computers is the one with LO fails while the one with Open Office succeeds.

Jim Quinn gravatar imageJim Quinn ( 2015-10-01 05:07:44 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-09-04 05:08:16 +0200

Seen: 7,646 times

Last updated: Sep 05 '15