Ask Your Question
0

Checkbox: possible bug in a form

asked 2015-09-06 16:21:05 +0200

BillPodmore gravatar image

updated 2015-09-07 21:51:37 +0200

If I create a form in base, using the wizard, from a table containing boolean fields then each of these fields is represented by a checkbox that I can ungroup and change the position of the label and then regroup again afterwards. However if, in edit mode, I add a checkbox then this cannot be ungrouped. When the 'group' option is selected then the message 'No selection possible' is displayed'. Have I stumbled across a minor bug, or am I missing something? I tested all this in a new database with just an ID and a boolean in the table with the results as described. I also correctly selected the checkboxes in the form. The checkbox generated by the form creation wizard can be ungrouped, but the checkbox added in edit mode cannot be ungrouped.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-09-08 02:49:02 +0200

doug gravatar image

I will surmise that the problem with the new check box is that is has a label that you cannot detach.

It's not exactly a bug, its just one of the more unintuitive features of LO Base form. The new check box was created with a label that, unlike other labels is not a separate control, and thus cannot be un-grouped. (If when you create the new check box you cannot see this, simply enlarge the checkbox "box" using the little green/blue boxes and you will see that when you created the check box in Edit mode, it automatically was created with a special kind of Label next to it.)

This label is populated by the entry in Control --> General --> Label. If you delete the entry in the property line, the CHECKBOX control will then not have the pseudo-label. Separately create a LABEL control and then hitch the two together using the Label Field property in the control box. In this manner, you can make the CHECKBOX label function the way you desire.

(if this answered your question please accept the answer by clicking the check box (image description) to the left)

edit flag offensive delete link more

Comments

@doug does this odd behaviour only apply to the check box control?

peterwt gravatar imagepeterwt ( 2015-09-09 15:02:01 +0200 )edit

@peterwt: some objects have that Label property, some don't. It makes more sense for control buttons and group boxes, less or check boxes and radio buttons. To explore, you can select an object, open the Control dialog, right mouse click to Replace With and cycle through the various choices.

doug gravatar imagedoug ( 2015-09-10 02:45:32 +0200 )edit

It all worked well; a, rather belated, thank you for the info.

BillPodmore gravatar imageBillPodmore ( 2015-09-13 07:39:42 +0200 )edit
0

answered 2015-09-06 23:12:27 +0200

peterwt gravatar image

The message suggests you have not selected an object on the Form. When you add the new checkbox click on it to select it. You will then get green squares around the Label and Checkbox. You can then Ungroup.

edit flag offensive delete link more

Comments

I did select the object, got the green squares, and then got the results I described. I'm using LO 4.4.5 and Windows 7 x 64 bits.

BillPodmore gravatar imageBillPodmore ( 2015-09-07 08:43:16 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-09-06 16:21:05 +0200

Seen: 624 times

Last updated: Sep 08 '15