Ask Your Question

Problem with a font [closed]

asked 2015-09-07 11:07:05 +0100

vieri gravatar image

updated 2020-08-18 22:06:33 +0100

Alex Kemp gravatar image

I have spreadsheet created with a Liberation Mono font, but every time when open a file the type of font is changed to Courier new, any idea to solve that ?

LibreOffice v. Mac OS Yosemite

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-18 22:07:03.053053

3 Answers

Sort by » oldest newest most voted

answered 2015-09-07 13:17:28 +0100

Alex Kemp gravatar image

updated 2015-09-07 22:46:18 +0100

Do you have the Liberation Mono installed in your system? If no, then you have your answer. If yes, then check to see whether you are making auto-replacements:-

(it should be there)

If this helps then please tick the answer (✔)

edit flag offensive delete link more

answered 2015-09-07 13:36:14 +0100

vieri gravatar image

Hi Alex,

Thanks for answer, I have installed the font on my system. And for solve that issue I made that was you say ... But there are any form to solve that without replacement table ?

Many thanks.

edit flag offensive delete link more


Hi Vieri, I suspect that Alex was asking you to check if there is an auto-replacement active that causes the change when you open the document, he was not suggesting that you create an auto-replacement to solve your problem :)

giampaolo44 gravatar imagegiampaolo44 ( 2015-09-08 17:35:09 +0100 )edit

The only way that I know of is the Replacement Table (and probably it was designed for your precise situation).

Thanks for the selection.

Alex Kemp gravatar imageAlex Kemp ( 2015-09-08 20:44:48 +0100 )edit

I've only just read what @giampaolo44 said; it is accurate!

Alex Kemp gravatar imageAlex Kemp ( 2015-09-09 20:15:42 +0100 )edit

I'll echo vieri's most recent question, because I do not think it was answered: Is there any other way to solve this problem without using the Replacement Table? The Replacement Table solves the problem, but it does not seem to be the ideal solution, because it seems that the "Font Settings for HTML, Basic and SQL Sources" setting (locate underneath the "Replacement Table") of Liberation Mono font should be sufficient. The reason is because, originally, I set the "Font Settings for HTML, Basic and SQL Sources" setting (locate underneath the "Replacement Table") to Liberation Mono without ever using/activating the "Replacement Table" and my workbooks would use "Liberation Mono" by default, as desired and expected. It was only after a recent update that I began to experience the same issue as the OP.

So, why is Courier New suddenly the default?

arya gravatar imagearya ( 2019-06-17 06:50:21 +0100 )edit

Question Tools

1 follower


Asked: 2015-09-07 11:07:05 +0100

Seen: 515 times

Last updated: Sep 07 '15