Ask Your Question
1

Anyone finding LibreOffice slow on OSX?

asked 2015-09-14 20:36:49 +0200

jedy gravatar image

updated 2015-09-15 17:11:02 +0200

Alex Kemp gravatar image

I'm using LibreOffice Version: 5.0.1.2 on a late 2011 Macbook Pro with OSX version 10.9.5 and 8GB ram.

I have just downloaded LibreOffice and have experimented inserting images in Writer. This causes it to become painfully slow and the cpu load for LibreOffice jumps up to 80%. It is slow to scroll up and down, moving the cursor and typing text. Seems OK before adding images although not as responsive as OpenOffice. This is a shame because the way OpenOffice handles inserting and manipulating images is really awful and LibreOffice seems so much better. I don't have the latest OS or 16GB of ram but I would expect the Mac I do have would be adequate - it certainly is for the latest version of OpenOffice. Anyone else experiencing sluggish behaviour using LibreOffice on OSX?

edit retag flag offensive close merge delete

Comments

Try upgrading to 5.1.0.3.

rautamiekka gravatar imagerautamiekka ( 2016-02-13 17:46:09 +0200 )edit

I've usede Lo for several years and after upgrading to ElCapitain it takes FOREVER to load the first time I open it, from then on it's fine till I reboot. I have OSX 10.11.6 and using LO 5.1.0.3.

I'll have to find something else because this is just too slow.

bob470 gravatar imagebob470 ( 2016-09-20 16:28:15 +0200 )edit

I have the same experience. Very slow to load first time, then it all seems pretty okay.

Thomas Bourchier gravatar imageThomas Bourchier ( 2017-03-02 12:25:44 +0200 )edit

Same here. When you put drawings into your spread sheet it is overkill. Hard to use at all. The "pizza" is showing up all the time. iMac i7, 12 GB ram and SSD.

tloehr gravatar imagetloehr ( 2017-05-05 11:46:39 +0200 )edit

And I thought the water boiled faster. I'm using LO 5.4.3.2 on a MacBook Pro with macOS High Sierra 10.13.1, 2.6GHz i5 CPU with 8GB DDR3, and SSD. I find LO extremely sluggish compare to MS Office for MAC. It takes long very long 5 - 10+ seconds to open and close files in writer, calc, and impress making it not that impressing. Not to mention the delays and sluggish action while editing documents especially when switching between say calc and writer. Is there a way to speed this up?

HerCorns gravatar imageHerCorns ( 2017-12-08 14:08:09 +0200 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2017-10-15 04:23:24 +0200

updated 2017-10-15 04:25:14 +0200

I have this problem. I've found the workaround described here works for me.

Summary: Launch directly from executable within the application archive (/Applications/LibreOffice.app/Contents/MacOS/soffice for me).

edit flag offensive delete link more
0

answered 2017-04-05 15:21:54 +0200

GBH gravatar image

Agree. Unusable it is so slow. Had to go to the Collabora free version from the App Store which is very fast. NeoOffice, also, is super fast. Not sure what the issue is with the LibreOffice version. I have tried every fix ever suggested and have plenty of ram, a fast SSD, etc. Nothing works.

edit flag offensive delete link more
0

answered 2017-04-02 21:26:23 +0200

As of March 2017 with 5.3 same problem persists.

edit flag offensive delete link more
0

answered 2016-01-04 12:25:32 +0200

AzaharTechs gravatar image

I am also finding this on all versions of v5, currently running 5.1.0.1 on OSX 10.11.2. Significant CPU spikes especially using Drawing and Presentation files. I have increased the memory settings as cache 512Mb and objects at 10Mb, but drawings are still quite laggy especially just zooming in/out. I have LO 4.4.7 also installed and when I open up the same file in that version, there is no lag. Definitely seems to be something introduced/changed in v5 codebase.

edit flag offensive delete link more

Comments

Try upgrading to 5.1.0.3.

rautamiekka gravatar imagerautamiekka ( 2016-02-13 17:46:00 +0200 )edit

Now using 5.1.1.3 and it's a little better, but not resolved. LO still has high CPU (+80%) after editing any drawing file after a few minutes. Only workaround is to drop back to to v4 to edit drawings. Write/Sheet files are not affected, and I don't use Presentation files enough to notice.

Was there something specific fixed in 5.1.0.3?

AzaharTechs gravatar imageAzaharTechs ( 2016-03-07 14:41:42 +0200 )edit
1

answered 2015-10-05 17:58:42 +0200

What size are your pictures? Did you try changing the settings in Preferences > LibreOffice > Memory?

edit flag offensive delete link more

Comments

I increased the memory settings as cache 512Mb and objects at 10Mb. I have an 8Gb RAM laptop, so these settings do not seem in anyway excessive. Perhaps too low? I will have a play with the settings and see if they have any effect.

AzaharTechs gravatar imageAzaharTechs ( 2016-03-11 11:53:44 +0200 )edit
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2015-09-14 19:33:52 +0200

Seen: 4,687 times

Last updated: Oct 15 '17