Ask Your Question
0

LibreOffice 5 for mac will only print landscape. Please help.

asked 2015-09-23 21:20:54 +0200

StacyBearden gravatar image

updated 2015-10-05 04:09:32 +0200

Alex Kemp gravatar image

LibreOffice 5 for mac will only print landscape. Please help.

edit retag flag offensive close merge delete

Comments

I also have this issue. Changing the page orientation under Format > Page ... does not change the orientation of the printed page. In the Mac print dialogue, the preview under the Libre office settings appear normal, (portrait) whereas the preview next to it on the Mac print dialogue shows the text printing in landscape orientation. When printing it is the landscape orientation that is printed.
Please help.

JCWallenburg gravatar imageJCWallenburg ( 2015-10-26 18:59:03 +0200 )edit

Just noticed that the answer below to a similar question ( https://ask.libreoffice.org/en/questi... ) provides a useable work-around. Basically, File > Export as PDF generates a pdf with the correct orientation. With gratitude to fulldecent...

I am having the same issue LO 5.0.1.2 on Mac 10.10 and 10.11. Documentation is at https://youtu.be/ARp6EJ7C0uk fulldecent gravatar imagefulldecent (Sep 18 '15)

JCWallenburg gravatar imageJCWallenburg ( 2015-10-26 19:13:12 +0200 )edit

Same problem here. PDF workaround is a great idea, thanks!

sharp11 gravatar imagesharp11 ( 2015-12-12 22:07:22 +0200 )edit

LO 5.4.1.2 and LO 5.3.6.1 on either macOS 10.12.6 (Sierra) & 10.10 (Yosemite) have the same 'landscape issue' with Letter Size (8.5"x11") while printing in portrait format.

My work-around is just to convert letter size to user-format (8.5" x 10.99") or (8.49"x11"), which don't have noticeable effect on the margins.

Exporting to PDF before printing works but annoying if you are in a hurry.

Rally gravatar imageRally ( 2017-10-03 16:06:29 +0200 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2017-10-10 05:01:57 +0200

mikel gravatar image

Problem still exhibited in MacOS 10.12.6

edit flag offensive delete link more
0

answered 2016-10-21 21:06:55 +0200

LibreLover gravatar image

LO folks must have tested it on A3 paper because it does not rotate it to landscape. So, until they fix it, you can use A4 Paper Format and set your margins to Left .79, Right .42, Top .79, and Bottom to 1.48. If you want something than the traditional size margins, you might have to do the math yourself.

edit flag offensive delete link more

Comments

MacOS 10.12.1 fixes this problem and the select problem.

LibreLover gravatar imageLibreLover ( 2016-10-25 19:49:57 +0200 )edit

This fixed it for me for now. I created a template with these settings, then set it as my default template. My documents now print out in portrait mode. For reference, I'm using Mac OSX 10.13.2 and Libre Office 5.3.7.2 and nothing else seemed to fix it.

pstallo gravatar imagepstallo ( 2018-01-18 05:04:22 +0200 )edit
0

answered 2017-10-31 18:55:42 +0200

LO 5.4.1.2 (OSX 10.10.5)

Here is a simple workaround I discovered for this issue. It seems to work most of the time but not always.

In the print dialog, click the "More" tab (next to "LibreOffice Writer" tab), change Include option from "All pages" to "Back sides / left pages". This reloads the print dialog with the correct page orientation and showing the back page (if you have only 1 page the back page will be blank). You may then change back to "All pages" and the correct page orientation remains.

Cheers Cap

edit flag offensive delete link more

Comments

This workaround is working on my config : macos 10.11.6 , with LO 5.3.7.2 . This bug is weird .

EchoMike999 gravatar imageEchoMike999 ( 2017-12-10 17:07:20 +0200 )edit

This worked after I chose more>"right pages" "checked brochure" "apply" and then chose more> "all pages", "uncheck brochure" "apply". Basically, changing the "more" options can trigger a return to "portrait" ...seems like a long time for such a prominent bug.

mweinmeister gravatar imagemweinmeister ( 2017-12-22 18:46:53 +0200 )edit

Thank you mweinmeister! Your steps worked for me in LO 5.3.7.2 on MacOS 10.12.2, leaving out the two steps "apply" which seem no longer to exist.

votermedia gravatar imagevotermedia ( 2018-01-29 21:25:40 +0200 )edit

Thank you!!! This worked for me. I was racking my brain trying to figure out why I couldn't get it to switch to portrait.

mvasilakis gravatar imagemvasilakis ( 2018-07-18 23:14:38 +0200 )edit
0

answered 2017-09-03 02:18:34 +0200

KaiNLee gravatar image

This problem has returned. LO 5.3.6.1, OS X 10.12.6

the work-around, to Export as PDF before printing, does work. But it is awkward. Maybe I need to go to MS Office??

edit flag offensive delete link more
0

answered 2018-02-01 05:14:23 +0200

Wow! Just fucking wow! This is still an issue. LO 5.4.2.2 OS X 10.13.3 What a joke!

edit flag offensive delete link more

Comments

May I suggest you choose your words more thoroughly?
Why did you judge your post above to be an answer?
Why did you enter this very old thread? There is nobody in charge of updating old threads if more recent ones contain better info.
Did you finally try V5.4.4? It was (inofficially) announced to fix the issue. Lacking access to a Mac I cannot test.

Lupp gravatar imageLupp ( 2018-02-01 10:21:16 +0200 )edit

May I suggest that if you don't have a Mac and can't intelligently comment on the problem the you STFU? "Inofficially" is not a word. V5.5.4 does not fix the problem.

BadBadDog gravatar imageBadBadDog ( 2018-02-02 16:28:36 +0200 )edit

Well, I'm not a native speaker of English, and sometimes I may type the wrong letter, but I recognize a rude fool even if he writes in English and uses those awesome acronyms.
Hope you find a better forum to boost it with your very first post.
BTW: There is no LibO version 5.5.y.

Lupp gravatar imageLupp ( 2018-02-02 17:06:57 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-09-23 21:20:54 +0200

Seen: 6,247 times

Last updated: Feb 01 '18