Ask Your Question
1

Slow, laggy UI in LibreOffice 5

asked 2015-10-02 13:24:43 +0100

bybauskis gravatar image

updated 2015-10-05 18:19:03 +0100

Alex Kemp gravatar image

I recently upgraded to 5.0.2 and the new interface is very laggy on my system for some reason:

  • When opening an .odt document, the toolbars load one by one, then the menu appears. This takes a few seconds.
  • Clicking / mousing over a menu first opens a blank grey rectangle, the actual contents appear after a fraction of a second
  • Scrolling through things like Extension Manager is very laggy
  • Menu fonts are slightly blurred and look ugly

I reverted back to 4.4.5.2 where the menus are nice and snappy like in any other program.

Maybe this is due to some sort of hardware acceleration? I tried disabling OpenGL in options, but it didn't seem to have any effect.

I'm running 64-bit Windows 10, Phenom II CPU, 4 GB RAM, and I have newest drivers for my Radeon graphics.

Can I somehow make LibreOffice 5 as fast and snappy as its previous version?

edit retag flag offensive close merge delete

Comments

I have this same problem except I'm still on Windows 7, but Libreoffice 4 rendered fine and 5 is terrible.

Jez gravatar imageJez ( 2017-05-18 20:38:09 +0100 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-10-05 18:28:29 +0100

updated 2015-10-05 18:32:36 +0100

There are 2 reasons:

1.1) Having too many dictionaries installed, at least on Window$, results in extreme CPU usage for no reason. I have all dicts installed on A4-5000 APU, a low-power quad-core, wastes a whole core, giving nearly no time for LO to function.

1.2) Be noted 5.0.2.2 aka 5.0.2 RC2, but not 5.0.2.1, suffers from #1.1. I've already reported #1.1 to TDF: https://bugs.documentfoundation.org/s...

2) If your GPU doesn't support OpenCL, regardless of beta drivers (be sure to check for beta drivers, they can work miracles even if the changelog doesn't concern you at all), there will be alot time wasted testing shit on GPU, only to notice it doesn't work, or works partially. You can disable OpenCL within LO, but that switches to CPU-exclusive processing, and being single-threaded program, LO calculations will be really slow, if GUI works

edit flag offensive delete link more
0

answered 2018-04-17 14:17:59 +0100

blacklist opengl completely solved my issue, still 4.2 is rocket fast

add following to your opengl blacklist file: share/opengl/opengl_blacklist_windows.xml

<entry os="all" vendor="all"> <device id="all"/> </entry>

edit flag offensive delete link more
0

answered 2016-08-15 17:24:22 +0100

chebum gravatar image

I had problems on Windows. One dive LibreOffice became slow as hell. Disabling OpenGL solved the problem. Open Settings. Go to LibreOffice - View. Disable OpenGL setting on the right. Restart the program. It looks like a driver compatibility issue that causes the problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-10-02 13:24:43 +0100

Seen: 18,665 times

Last updated: Apr 17 '18