Ask Your Question
0

Extra line spacing in first line of text paragraph

asked 2015-10-03 23:06:49 +0100

Orpheus99 gravatar image

Sometimes--and sometimes "often"--when I paste text from another source such as a web page, the first line of text in the paragraph has about 1/2 extra line space between that first line and the second line.

When I examine the default and text body styles, I cannot find a way to remove that 1/2 extra line space between that first line and the second line. It does not seem to correspond to any of the paragraph style settings.

1) Any idea what causes this, what might be embedded in the html text I am pasting as text?

2) How can I remove that 1/2 extra line space?

edit retag flag offensive close merge delete

Comments

Have you tried turning on hidden characters in LO Writer? Have you tried pasting the copy buffer to a plain text editor such as Notepad, then copying from Notepad to Writer to see if the problem persists?

LKeithJordan gravatar imageLKeithJordan ( 2015-10-04 05:03:02 +0100 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2015-10-04 15:10:33 +0100

Alex Kemp gravatar image

Hi Orpheus99

You mention neither LO version nor OS+version, so that closes down some possibilities to help.

I think that the simple answer is to stop pasting HTML & paste plain text, then format as you wish. @pierre-yves samyn has already given you the method to fix your current issues:-

Remove Existing Problems:

  1. Select problem section
  2. (menu):FormatClear Direct Formatting (Ctrl+M)

Prevent Future Problems:

(menu):EditPaste Special... (Ctrl+Shift+V)
(then choose Unformatted Text)

A quick test just now under 5.0.0.5 shows 2 options with Ctrl+Shift+V after Ctrl+C on a section of this page:

  1. Unformatted text (mime: text/plain) (default)
  2. HTML (HyperText Markup Language) (mime: text/html)

That means that Ctrl+V (EditPaste) would paste just plain-text. However, I've noticed in earlier versions that text/html was the 1st (and therefore the default) option. That is Not a Good Idea™, as odd fonts & formatting are almost certain to get inserted.

PS
My early experience of LO under Debian was that the copy/paste duo was very problematical. It has become more solid as the versions have continued to be released.

If this helps then please tick the answer (✔)
...and/or show you like it with an uptick ()

edit flag offensive delete link more
0

answered 2015-10-06 16:09:11 +0100

LKeithJordan gravatar image

Given your last post, here is another suggestion that might have some success. Print the html page to a pdf file, using a pdf printer driver (or print and then scan the document to pdf). Then convert the pdf to a MS-Word or odt format. There are plenty of ways to accomplish this. This approach might allow you to preserve the desired formatting.

Another idea (if you don't mind doing some work) would be this: 1) copy and paste the html into an odt with formatting;
2) scan for superscripts and append them with a special unique sequence, such as "~/" (without the quotes);
3) repeat step 2 for subscripts (but use a different unique sequence, such as "\~");
4) copy document text and paste it into a plain text file;
5) open the plain text file with LO Writer;
6) search for your special unique strings, manually apply the desired formatting to the superscripts and subscripts, and remove the unique strings

Depending on how many references you have, this could be a lot of work, but at least you would have preserved the subscript and superscript formatting you indicate is so important.

edit flag offensive delete link more
0

answered 2015-10-04 07:23:41 +0100

pierre-yves samyn gravatar image

Hi

Have you tried Format Clear Direct Formatting Ctrl+M ?

You can also have a look to Tools Options Writer Compatibility: some options add spacing.

Regards

edit flag offensive delete link more
0

answered 2015-10-06 10:04:05 +0100

Orpheus99 gravatar image

I've temporarily forgotten the specific document it was I was working on.

The problem, in that case, with pasting as plain text is that I lose much of the work of formatting, given that the original text (html) had super- and subscripts, which are/were essential to the meaning of the content.

I suppose that by remembering to use the character formatting tools, I could reformat the plain text as intended into the requisite algebra...

Thanks for all of your comments, all of which I tried, AFAIK, and since we're up to 5.0.0.5, that is good news for me: 5.0.0.1 took about a half an hour to save a simple text change--on my system, at least-- so I'm still back at 4.4.1.2, for now.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-10-03 23:06:49 +0100

Seen: 272 times

Last updated: Oct 06 '15