Ask Your Question
0

Assigning "paste unformatted text" prevents pasting pictures

asked 2015-10-17 23:02:30 +0100

Genom gravatar image

updated 2016-03-16 23:02:16 +0100

Alex Kemp gravatar image

Hi,

Sorry for the cryptic title but I have this following problem and I need your help / advice to submit a bug report.

On my Ubuntu 14.04 and LO 5.0.2.2, I set the keyboard short cut CTRL + V to "Paste unformatted text" to copy text from various sources to my document, without messing with my formatting. But after setting this option, I was no longer be able to copy and paste images, even if they are within the same document. However, I can paste the copied image from the Edit menu. I think "paste unformatted text" command cannot handle images but it should. What do you think? Is there an easy way to fix this?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Would CTRL-SHIFT-V do the same thing in Ubuntu? In Windows, that brings up the Paste Special Dialog and will give you different paste choices depending on what's in the clipboard. Then you can keep CTRL-V as the default paste function.

Rugslug gravatar imageRugslug ( 2016-03-17 00:52:27 +0100 )edit

LO commands are identical as much as possible across all OS; I've only ever heard that the Tools→Options command differs in Mac (I cannot recall at this moment exactly where it is). CTRL-SHIFT-V is definitely identical in both Windows + Linux.

Alex Kemp gravatar imageAlex Kemp ( 2016-03-17 02:22:30 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-03-17 08:54:43 +0100

pierre-yves samyn gravatar image

Hi

May be a bit complicated to use (several fingers), but in the windows version the keyboard shortcut for "Paste unformatted text" is already defined: Ctrl+Alt+Shift+V

The solution might be to use it and keep the default shortcut for CTRL+V?

Regards

edit flag offensive delete link more
0

answered 2016-03-16 23:28:46 +0100

Alex Kemp gravatar image

Duh...

Ctrl-V (or Shift-Insert)) is THE standard command (both Windows + Linux) to Paste items placed into the clipboard by using Copy (Ctrl-C or Ctrl-Insert).

Items are differentiated within the Clipboard by their MIME types and, in normal circumstances, there are multiple items copied by each Copy command. The one common item is normally “Unformatted Text”, which has the MIME-type ‘text/plain’. Indeed, if I have it correct, the only item copied into the clipboard at introduction was ‘text/plain’, and the whole MIME thing was a later update (which probably coincided with the introduction of the Ctrl-Insert/Shift-Insert combo).

The important issue is that ‘text/plain’ is exactly what it says on the tin:- plain text.

Thus, I am discombobulated by your statement “‘paste unformatted text’ command cannot handle images but it should”. This is a little like complaining that Salt tastes salty and should really taste sweet. The only response can be, “‘yes, that's right’ and ‘no it shouldn't’”. If you want images then you look at ‘image/jpeg’ or ‘image/png’ or a hundred others; you certainly do not look at ‘text/plain’.

edit flag offensive delete link more

Comments

Sorry for late response but it is not true. Your analogy doesn't fit and I'll explain why. Setting the option to copy text as plain text is different then manually each time pasting "Unformatted Text". The first one applies to each case where user wants to paste any text. If most recent item in the clipboard is an image, this option should be ignored any way. If user manually pastes something with the choice "Unform. Text", then the user implies he/she wants to paste a text.

Genom gravatar imageGenom ( 2016-11-11 14:57:52 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-17 23:02:30 +0100

Seen: 775 times

Last updated: Mar 17 '16