Ask Your Question
0

How can I exclude US spellings from spellchecks of a UK English document?

asked 2015-10-23 13:26:29 +0200

shinyford gravatar image

updated 2015-10-24 17:59:32 +0200

Alex Kemp gravatar image

LibreOffice 4.4.2.2. Writer - dictionary problem.

I've managed to get UK English dictionaries and thesauruses installed, but for the life of me I can't get the American spellings excluded in a spell check.

So if I have two words:

color colour

side by side, both are marked as spelled correctly. Now, I love America but sometimes when writing for a UK audience I really need the spell check to only allow UK spellings through.

As best I can tell I only have UK dictionaries installed. LibreOffice locale is en_GB. Language of the document is set to English UK. I've grepped for 'color' in all the dictionaries I can find, and I'm pretty sure it doesn't exist as a word in its own right. (It's in the en-GB dictionary as part of words like 'coloratura', but that's fine for UK English.)

And yet, it's still marked as spelled correctly. So is 'colour'. 'Colur', however, quite correctly gets a red squiggle, so obviously the spell check is working.

Does anyone know how to exclude American spellings from a spell check while keeping UK ones?

Many thanks

Nic

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-10-23 17:49:28 +0200

petermau gravatar image

I can't reproduce your problem on my 5.0.0.2 LibO running under Linux-Mint Mate 17. For me color is incorrect with English (UK) specified, as it is on this web browser. Colour is incorrect on US-English, and both incorrect with French. If in doubt, people often suggest resetting the profile to see whether this helps. Details of how to do this are scattered through the forum, for example https://ask.libreoffice.org/en/questi... . Remember to take a backup first.

You don't say what operating system you are using, in case there is an OS dependency with your problem... sorry to not help further.. Peter

edit flag offensive delete link more
0

answered 2015-10-24 18:53:35 +0200

Alex Kemp gravatar image

updated 2015-10-24 18:57:33 +0200

Hi shinyford

I cannot reproduce your issue (LO-5.0.0.5 en_GB.UTF-8 under Debian 6.0).

It is normally a setup issue. Unfortunately, there are 2 things to check in (ultimately) 4 different places.

Here's a simple step-by-step:-

  1. As petermau suggests, Reset your Profile (Q59016)
    (it is non-destructive + easily reversible)
  2. Check your languages:
    (menu):ToolsOptions...Language SettingsLanguages
    Languages
    (it may help if your UI+Locale are identical to the doc language, but should make no difference)
    (the important issue is the ABC + blue ✔ within Default Languages for Documents)
    (the ABC + blue ✔ says only that the language can be spell-checked, not that it will be)
  3. 2nd Check for Language:-
    (menu):ToolsLanguage
    image description
    (all 3: For Selection, For Paragraph, For all Text)
    (needs to be the same for all 3)

If at the end everything looks sane, then you have added those American spellings to your local dictionary.

If this helps then please tick the answer (✔)
...and/or show you like it with an uptick ()

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-10-23 13:26:29 +0200

Seen: 4,028 times

Last updated: Oct 24 '15