Ask Your Question
0

questionmarks instead of cyrillic letters

asked 2015-10-23 22:08:41 +0100

Pomerania gravatar image

Hey all,

just commented a cyrillic text in cyrillic letters, but after saving the documents the characters in comments changed to questionsmarks in contrast to the latin letters which remained unchanged. The main text is, however, represented correctly. The changing of the character type in the comment bubbles didn't help.

Many thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-03-16 13:04:34 +0100

Alex Kemp gravatar image

LO default is UTF-8. Assuming that you have not changed that default (you are on your own if you have) then a glyph which is a ‘?’ indicates that the font in use does not contain a proper glyph for that Unicode character. Thus, to fix this you will need to change the font used for Comments to one which contains glyphs for all the chars that you are using.

edit flag offensive delete link more
0

answered 2016-03-16 14:51:21 +0100

petermau gravatar image

If you are getting a � character (U+FFFD) instead of the ШϸѬЏБ that you entered I would expect this to normally be a character error rather than a font problem. Font problems would normally be little rectangles a little like the . The latter can be a missing character in the font or the one chosen by the Font Replacement Table.

If it is the former � this can often be found in Windows system by cutting and pasting text where the Russian is not understood by the pasting program or one is using a keyboard set to Russian iso-8859-5. This would not produce valid Unicode.... Interesting question..Peter

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-23 22:08:41 +0100

Seen: 269 times

Last updated: Mar 16 '16